Trouble with deploying RAID via Ignition

I’m having trouble with setting up RAID using Ignition. I’ve tried defining it manually and also using this method (Examples - coreos/butane). Each time it looks like GRUB is written to the MBR, but while the BIOS isn’t reporting that it can’t find an OS, I’m not even getting a GRUB prompt.

Does anyone have an idea of why this isn’t working?

1 Like

The config in that gist wipes the existing partition table and creates a RAID for the root partition, but does not create a root filesystem, /boot partition or filesystem, EFI support partition, or BIOS boot partition. I highly recommend using the Butane boot_device.mirror sugar instead of recreating the partition tables by hand.

If boot_device.mirror isn’t working for you either, could you post the config that isn’t working, and the BIOS error message you’re getting?

1 Like


I did try that sugar as well when I was troubleshooting this, and I had no success as well. I’m not getting any error from the BIOS, and if I run file against where the MBR should be on the disk, it does manage to find it, but I’m guessing something is breaking down between the MBR and the initial stages of GRUB coming up.

Again, please post the sugared config that’s not working for you. I assume the first boot is successful and the second one fails? The journal or console log from the first boot would also be helpful.