Trixieua/mutter-patched

Everything works now, thanks you a lot!

Wow. I have never used tripple buffering on Gnome and I thought I would try this out of curiosity.

The. Difference. It. Makes.

Basic desktop tasks seem so much smoother now! Thanks!

1 Like

Hi, thanks for the great repo, tripple buffering is working like a charm on my laptop.
Is it also possible to include 3304 for Fedora 39? It is ready to be merged and will improve performance on many notebooks where Nvidia dGPU is connected to displayport.

Sadly 3304 is not compatible with triple buffering patch so i cant include it in this repo.

Hmm strange,
In the above merge request some people were able to include TB+Nvidia Copy, there is even repo which is combining these two MRs 3304+1441 but it is not working on my Fedora Silverblue 39 for some reason.

Trying to install the patch from copr repo, when I try to do dnf update --refresh some packages might be causing conflict…

  • Fedora: 39
  • Gnome: 45.5
Problem: cannot install both mutter-common-45.5-1.fc39.noarch from updates and mutter-common-45.4-10.fc39.tripplebuffer.noarch from copr:copr.fedorainfracloud.org:trixieua:mutter-patched
  - package mutter-45.4-10.fc39.tripplebuffer.x86_64 from copr:copr.fedorainfracloud.org:trixieua:mutter-patched requires mutter-common = 45.4-10.fc39.tripplebuffer, but none of the providers can be installed
  - cannot install the best update candidate for package mutter-common-45.0-12.fc39.noarch
  - cannot install the best update candidate for package mutter-45.0-12.fc39.x86_64
==============================================================================================================
 Package       Arch   Version                    Repository                                              Size
==============================================================================================================
Upgrading:
 gdm           x86_64 1:45.0.1-11.fc39.clang     copr:copr.fedorainfracloud.org:trixieua:mutter-patched 873 k
 mutter        x86_64 45.4-10.fc39.tripplebuffer copr:copr.fedorainfracloud.org:trixieua:mutter-patched 2.6 M
 mutter-common noarch 45.4-10.fc39.tripplebuffer copr:copr.fedorainfracloud.org:trixieua:mutter-patched  13 k
 xorg-x11-server-Xwayland
               x86_64 23.2.4-10.fc39.clang       copr:copr.fedorainfracloud.org:trixieua:mutter-patched 995 k
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 mutter-common noarch 45.5-1.fc39                updates                                                 20 k

Transaction Summary
==============================================================================================================
Upgrade  4 Packages
Skip     1 Package

And when I add the --allowerasing flag to the update command,

 Problem: The operation would result in removing the following protected packages: gnome-shell
==============================================================================================================
 Package       Arch   Version                    Repository                                              Size
==============================================================================================================
Upgrading:
 gdm           x86_64 1:45.0.1-11.fc39.clang     copr:copr.fedorainfracloud.org:trixieua:mutter-patched 873 k
 mutter        x86_64 45.4-10.fc39.tripplebuffer copr:copr.fedorainfracloud.org:trixieua:mutter-patched 2.6 M
 mutter-common noarch 45.4-10.fc39.tripplebuffer copr:copr.fedorainfracloud.org:trixieua:mutter-patched  13 k
 xorg-x11-server-Xwayland
               x86_64 23.2.4-10.fc39.clang       copr:copr.fedorainfracloud.org:trixieua:mutter-patched 995 k
Skipping packages with conflicts:
(add '--best' to command line to force their upgrade):
 mutter-common noarch 45.5-1.fc39                updates                                                 20 k

Transaction Summary
==============================================================================================================
Upgrade  4 Packages
Skip     1 Package

Does going ahead with this command will seriously delete the gnome-shell package?

I cant get triplebuffer to apply to gnome 45.5 so dnf doesnt really know what to do because it wants to install packages with newest versions. Maybe i can “fake” the version of my package but still ship 45.4 inside but i dont really want to do that. For now you can get rpm’s from here and here and add exclusion to /etc/dnf.conf so it will ignore gnome-shell mutter and mutter-common packages.

1 Like

I see… so I’ll have to temporarily mark these packages gnome-shell, mutter, mutter-common as exclude from update. And will revert those when I upgrade to Fedora 40.