Transmission 4.0.1 all trackers get connection failed

So I got the update from transmission 3 to 4.0.1 on my Fedora 37, and as the title says, it wont connect to any trackers or peers.
Version 3 works perfectly or any other bt client for that mater, I tried changing settings and what not to no avail.
Is this a bug, or has something changed with version 4 that wont work behind NAT? I have been searching the web for some kind of clue for a while now but haven’t found a solution other than holding the packages to version 3.

Check if works for you.

Some BitTorrent trackers whitelist clients by name and version.
It takes manual action on the part of the tracker admins to allow the new client.

Thanks for the input, regarding this particular tracker, it connects and shows the number of peers available, but it won’t connect to any peers. Again, transmission 3.0 worked well. Other trackers I’ve tested will not connect.

1 Like

That’s weird as it works fine for me.
Try resetting Transmission settings to defaults:

pkill -9 transmission
gio trash ~/.config/transmission

I don’t know if it’s related, but I think I had to enable transmission-client service in firewalld to open the default port (51413).

My current firewall allowed services (your zone may be different):

$ firewall-cmd --get-active-zones
  interfaces: enp3s0
$ firewall-cmd --zone=home --list-services
dhcpv6-client kdeconnect mdns mpd samba-client soulseek ssh transmission-client

To add transmission-client service:

$ firewall-cmd --zone=home --add-service=transmission-client

If it works, make it permanent:

$ firewall-cmd --zone=home --add-service=transmission-client --permanent 

If you use a different fixed port you may have to add the specific port instead. Not sure about random port.

Here is the log from the fedora tracker:

|qui mar  9 21:01:50 2023|Information||Port 51413 forwarded successfully|
|qui mar  9 21:01:50 2023|Debug||readnatpmpresponseorretry succeeded (0)|
|qui mar  9 21:01:45 2023|Debug|Fedora-Workstation-Live-x86_64-37 at|tracker knows of 379 seeders and 7 leechers and gave a list of 80 peers.

After this it just sits there and does not connect to peers.

Any one with a similar situation?
Transmission 3 just works, so it must be something with transmission 4.

Perhaps your problem is specific to the current configuration.
Try to isolate the issue by testing a new user with default profile settings.
By the way, it works for me with no problem.

Yes, I thought as much, so I tried that with a fresh install on a vm and got the same result.
Even worst, on a windows 10 vm transmission 4 works very well, this is very weird and annoying.
I noticed manjaro did not move to transmission 4 (and they are a rolling release), maybe transmission 4 just not ready for main stream usage. :thinking:

Same here, Fedora 38 beta fresh install, transmission 4.0.2 won’t connect to any peer, no matter what torrent I try. Other torrent clients work just fine unless transmission is open, in which case none work. Haven’t tried 3.0 tho.

I’ve tested Transmission 4.0.2 in a live session of Fedora 38 Beta running in a VM like this:

sudo dnf -y install transmission-gtk

I moved the download location to /tmp since free space is limited in a live session.
But it still works fine for me.

Just tried again with the rpm build (was using flatpak) and ran into the exact same problem, is there any way to take logs or see what’s happening? Running transmission from the terminal doesn’t output anything.