TPM module not identified - F38

Hi, I have noticed in the last 3 kernel updates none of the kernel identifies my TPM. I say last 3 because my install is fairly recent, I cannot comment on the kernels previous to this. I noticed this when trying to configure disk decryption using TPM but since the kernel no longer identifies the TPM module I need to enter the password manually everytime.

My latop does have a TPM module. When I used the Fedora 38 workstation image (kernel 6.2.9 I think) it identifies the TPM out of the box. Only after a kernel update this breaks.

I understand this might not be a Fedora issue but a kernel issue, but I believe this would break systems where TPM based decryption was already configured and a kernel update would render the system un-loginable.

Something similar - 217631 – Kernel 6.4 failing to access TPM on Framework Laptop 12th gen
Not sure if this is impacting a certain set of machines. But I am running a Asus F15.

I had tried Ubuntu 23.04 but since they are running on kernel 6.2.x it is all good.
I think the issue is on 6.4.x series.

1 Like

Welcome to Fedora @minima1cha0s

You could use the LTS kernel as long you have troubles with the newest one.
If you install it additionally you will have the chance to test it once a while.

kwizart/kernel-longterm-6.1 Copr

That said, do you know where to properly report it as a bug? I’ve been having the same issue, and it seems like it’s an upstream thing, as some folks from NixOS have been facing the same issue, so I don’t think just reporting on our Bugzilla helps a lot.

EDIT: nevermind, it’s already been reported on Bugzilla


I tried this out because it makes sense not to upgrade the kernel every month, but I am unable to sign using akmod keys for secureboot. Unable to boot into it.

I am able to downgrade to kernel 6.2.9 where it identifies TPM but next time an update appears it will remove the oldest one which is ideally the only working one. I understand I can exclude updates in dnf but ideally a non-technical user wouldn’t go through all this hassle and switch distro.

Seems the fix is out for kernel 6.4.15 -

Not sure when it will be available on stable branch though

1 Like