Touchpad not working in Lenovo Thinkbook


After installing F38 in Lenovo Thinkbook, the touchpad is not working.
Any suggestions?
Please help.


Mallikarjun, the first thing you might try is to search for your subject in this discussion forum, see what information the contributors here have asked for, and also look at their solutions. You’ve not provided information to set context for your particular problem.

HI @mhdave ,

Very sorry for not providing the required information.
I had checked for posts such as:
Touchpad not working in Fedora 34 - #3 by mgvia69, and
Touchpad on Lenovo Yoga not working after new F37 install - #4 by grumpey,
but, the solutions providing didn’t work.
Please let me know if additional information is needed.


OK, you checked the posts, and as you did you saw the sort of information that might be useful in diagnosing the problem. Generally it is a good idea to both check to see if other posts can lead you to solving your own issue, and seeing the information exchange that was requested or provided in the process so that you can provide the same. The guides to new users generally ask that you first search the forum to see if your issue has been solved elsewhere, and if not, that you describe what steps you’ve taken in your own attempts to resolve this.

Hi @mhdave , Thanks. Will follow it.

I’m providing the details of my system for accurate debugging.
Please let me know if any other information is required.

As I looked into the other issues similar to this, I have understood that the kernel needs to be updated to include the drivers for the touchpad of this device.

I tried some solutions regarding updating the “/etc/grub/default” file, but that didn’t work.

Any solutions or suggestions, please let me know.