Touchpad Lag when Plugged In with Slow Charger


I’ve got an intermittent issue that I’m struggling to debug.

In typical operation, my touchpad is very responsive, and feels smooth. However, occasionally, something happens and it becomes significantly less responsive. Looking at the motion I think it’s still polling at the same rate, however, the mouse pointer updates about 200-500ms after I move my finger on the touchpad. I don’t know the exact difference, but it’s quite noticeable.

I experienced this on a fresh F36 install, and it appeared to happen at random intervals.

Now I’m running the F37 beta with an additional 6.1.0-0.rc0.20221007git4c86114194e6.5.fc38.x86_64 kernel from rawhide. It’s happening less, however, still appears to consistently happen when I plug my laptop into a slow-charging USB-C charger.

I’m using Gnome with Wayland exclusively, and my hardware is a Thinkpad T14 Gen 3 AMD with a 6850U APU. Running the LENOVO 21CFCTO1WW/21CFCTO1WW, BIOS R23ET59W (1.29 ) 09/01/2022 bios, latest as of last week.

I don’t think this is Fedora-specific. I experience a very similar issue on my work laptop, which is a Dell Latitude 5520 with a 13th-gen Intel processor running Ubuntu 22.04. It’s also using Gnome on Wayland. The main difference is that on that laptop, the touchpad is always slow when plugged in, and immediately speeds up when unplugged, and it’s always the exact same two states: either perfectly responsive, or delayed the exact same slow amount.

On my Thinkpad T14 Gen 3 with Fedora, it doesn’t always slow down when plugged in - sometimes it’s completely the same, and sometimes it slows down a tiny amount. Also, when it’s fully laggy, unplugging does not fix the issue - I have to systemctl suspend and resume before it becomes snappy again.

I don’t notice anything in htop when the mouse is lagging vs. not.

The keyboard does not lag when the mouse lags, so I’m fairly sure it’s a touchpad issue, not a display driver issue.

It’s almost most annoying when it very slightly slows down, because then it’s still usable, but I have to adjust my fingers so I can still hit things accurate. And it feels so crisp and snappy when it’s working at its best! Just annoying to have it slightly off.

My question is: where on Wayland can I look for logs related to this? Any tips on if I can enable verbose logging in a touchpad driver, or anything else you’d recommend looking at?

Related posts:

Experiencing the same issue on my Hp Elitebook G6 with Arch 6.0.8

Ah, I’m glad it’s not just me!

Is there any chance you’ve experienced any other weird touchpad issues?

One that’s happened a few times to me is, seemingly completely randomly, my touchpad will stop registering 1-finger touches, and like, treat 2-finger drags as 1-finger drags, 3-finger as 2-finger, etc. It goes back to normal after 10 seconds - 10 minutes usually.

I haven’t figured out anything about the main issue, the increased latency on touchpad inputs especially after being plugged in, unfortunately.

Hello there! I am also experience touchpad problems on a Thinkpad T14 Gen 1 AMD. I didn’t realize it was triggered by connecting the AC, in my case is fast charging. I don’t remember happening on F35 but certainly on F36 and now on F37.

I don’t have the other problem you describe, but rarely when I wake up the system from sleep, the mouse inputs breaks (left clic doesn’t work, right clic becomes left clic), but this also affects an external mouse so may not be related.

1 Like

Thank you for the info!

I should mention, when I charge, I am only ever fast-charging using a third party charger. I’ve heard reports in other threads that this doesn’t occur with the original laptop charger cable fro some laptops, so it’d make sense if it didn’t occur slow-charging as well.

I myself seem to have more problems with some of my chargers than others (the 4-port Anker PowerPort Atom PD 4 seems to produce more problems than the 1-port Anker 65W PIQ 3.0 PPS), but honestly I can’t tell if this is real or just my imagination.

I don’t use an external mouse with this laptop, but I do have an integrated TrackPoint (Thinkpad nib), and it always works perfectly even when touchpad input is completely broken. So, I suspect that if an external mouse is cutting out too, that’s probably a different problem?

I should also say, I have no update on fixes or anything else. Everything still occurs for me as described originally, and I’m currently just mostly using the laptop on battery power and not using it when recharging.

I’m having the same issue with my T14 gen 1 AMD. I’m using a 90w power adapter from RavPower. Have you figure out how to fix it?

No luck. I have been trying to debug it but couldn’t figure out anything. It certainly happens more often when connected to the AC (i am using the original 65w adapter), but I feel that sometimes it also happens when on battery.

I have yet to try to boot into a live usb image and see if the problem persists.

On a side note, I just found this post on the lenovo forum related to a bugged touchpad firmware released on june/july this year. The post doesn’t say anything about lagging touchpad, but mentions another problem that I had sometime ago and don’t know if it’s related. I am trying to check what version of the firmware I have installed, because I definitely had that problem but it hasn’t happened in a while.
They also just released a new firmware (fixing the above issue) but say it has only been tested on windows and may take a while until it arrives to linux.

This doesn’t apply to David (op), for what it seems the issue affects synaptic touchpads but AFAIK the T14 Gen 3 comes with elan touchpad.

Ok so I tried a couple of things and came to the conclusion that must always been like this or something is faulty on my hardware (and yours too?).


  • Booting on live images of fedora 35, 36, 37. All of them presented the problem.
  • Downgrading the bios from 1.41 to 1.36 (dec 2021).
  • Disabling power management features on bios and linux (disable power-profiles-daemon)
  • I think I have never updated the touchpad firmware (2909640), there isn’t any on the linux firmware thing.

Adding to the list of problems, it becomes much worse and noticeable when I connect the laptop to an external TV. It’s miles worse than when connected to the charger.

I’m lost.

Sometimes the problem gone after I boot into Windows then back to Fedora (I use both Windows and Linux on same machine). But that way doesn’t fix the problem completely, It returned after I reboot. Too painful, I ended up using an external mouse.

Got the same issue after upgrade fedora 36 from 34.
Used Thinkpad_x260, 3 OS (Windows10, Ubuntu16.04, and Fedora36)
It’s annoying. Hope can fix the bug.

I don’t know much about this so don’t take it as a truth, but some people in internet say that it may be the static energy, power outlet or charger that’s causing it.

At least in my case I suppose this is the reason, I am not sure why I didn’t notice before but for sure that’s why the touchpad lags when I connect to my cheap tv.

True. My workaround for now is booting fedora before plugging charger or any other external devices. After it booted into log in screen the touchpad works (still works after I reconnect the charger, external keyboard, mouse …)

Hi, just got a brand new Thinkpad, a T14s Model gen 2, AMD and all, I’m on F37 and I just noticed this issue, it seems that it does come when charging, I’m even using the original 65W adapter.

Darn, that sucks!

Mine at least does work reliably if I use a single-port 65W charger (as opposed to a 50W port on a 100W charger). I don’t have the original charger to try, but I assume it’s equivalent.

Probably the difference between the Elan touchpad in the gen3 and the synpatic one in the gen 2…

This doesn’t apply to David (op), for what it seems the issue affects synaptic touchpads but AFAIK the T14 Gen 3 comes with elan touchpad.

(from Touchpad Lag when Plugged In with Slow Charger - #7 by fygonzalo)

On that note, seeing this:

They also just released a new firmware (fixing the above issue) but say it has only been tested on windows and may take a while until it arrives to linux .

(from the same post)

if you have a new touchpad firmware available in Windows, and have Windows installed, it might be worth booting in there and seeing if you can update to that.

I found your post and it was really helpful, same laptop, same issue.

About chargers, I had other experiences, including touchpads and touchscreen working erratically if not at all with noisy chargers, and fixing that by turning the power cable around a piece of metal.

The behaviour of this hardware is better as it can manage to work despite the noise, even though in a degraded way.

Would be nice if the hardware could detect the situation and make it visible via software, so the user can take action, for example none if the touchpad is not so needed, or run on battery when doing tasks where the touchpad needs to work precisely, or get a better quality charger.

1 Like

I think I’m going to have to get a Windows install running on this laptop to see if it has any firmware upgrades available the Linux one doesn’t. I think I kept the original install on the original SSD.

I’ve been running into more touchpad issues that may or may not be related, and I may have mentioned. Specifically, the past week, a few days the “number of fingers” counter has appeared offset by one. A single touch does nothing, two fingers is treated as a single finger, and three fingers as two (so three fingers to scroll, two to move the cursor).

The kicker is that as soon as it occurs, this behavior sticks around until the device is powered off and turned on again. Restarting, without a full power off, doesn’t fix it!

That’s the main reason I’m fully convinced that, regardless of whether there are additional software or kernel issues, there is at least some bug in the firmware running on this touchpad.

If Windows doesn’t have any additional firmware updates available, or if those don’t fix it, maybe I can try to reproduce the issue on Windows and get support, or a warranty replacement… Not that I expect that would help, but like, it couldn’t hurt to try.

If anything changes for me I’ll report back.