Touchpad and Trackpoint lagging

Hi there. I’m not a fedora user myself but was asked for support by a fedora user whose trackpad+trackpoint is not working correctly. The issue might be related to this one: Mouse sensitivy problem (the person opening the issue wrote it magically solved, however it seems unclear what the issue was). After most reboots, the trackpad is either extremely slow, or driven towars some corner of the screen when resting, or just lagging/hopping over the screen. sometimes the trackpad is completely unresponsive. Sometimes, it just works as it is supposed to until the next reboot. Since the trackpad is misbehaving even when not touched, it does not help as a workaround to connect a USB mouse unfortunately.

They have a Lenovo X1 Carbon Thinkpad (4th gen) with fedora workstation 38 installed. We updated to v39 to make sure it has the latest drivers but that did not help. They installed fedora roughly a year ago with no problems, and these issues started some weeks ago.

Things we tried:

  • check input with libinput-debug-events → the input signals each for themselves seem to work fine (leftclick, rightclick, moving in directions) only the timing and sensitivity are broken

  • adding psmouse.synaptics_intertouch=0 to the kernel parameters → this seems to fix some issues of this kind, did not help unfortunately

Logs

The only usable error log I could get is this:

(udev-worker) [1072]: event5: Failed to write 'sensitivity' attribute: Input/Output error

I verified that event5 is in fact the identifier assigned to the touchpad so I am pretty confident this has to do with the problem, only searching the web for the meaning of this message did not get me any further. I am not even sure if I understand the problem: Is udev reporting an Input/Output error with the phyiscal device? where is this sensitivity attribute written? and can I debug it somehow?

Any advice on how to debug this further, possible workarounds or hints on what could be the root cause would be very appreciated!