Totem is missing plugin "Source protocol SMB"

Hi all,

On a (up to date) Fedora 33 Workstation, I want to play a file located on a SMB share (video or music) with Totem (Gnome Videos app).
When I do so, I get the following error (terminal output):

plugin: gstreamer|1.0|totem|Source protocole SMB|urisource-smb (Source protocole SMB)

I think I have all required packages:

  • gvfs-fuse
  • gvfs
  • samba
  • samba-client
  • gvfs-smb
  • gnome-vfs2-smb

but it does not work. I have all packages required to play the file format (codecs installed from rpmfusion).
Is there anything I miss ? It works fine with mpv.

Thank in advance for any pointer.

I searched for your error and wonder if you have all the gstreamer1* packages from rpmfusion installed. There was a bug reported in 2007 that totem had the same smb error because it needed a gstreamer package (plugin) for the smb protocol to function.

You might consider reporting this as a bug against totem if you install the gstreamer packages and the error is solved. It would seem a missing dependency in that case.

Thanks for your answer.
I think I have the packages needed by Totem:

# dnf --disablerepo="*" --enablerepo rpmfusion* list installed | grep gstreamer
PackageKit-gstreamer-plugin.x86_64                 1.2.2-2.fc33                         @updates
gstreamer1.x86_64                                  1.18.2-1.fc33                        @updates
gstreamer1-libav.x86_64                            1.18.2-1.fc33                        @rpmfusion-free-updates
gstreamer1-plugin-openh264.x86_64                  1.16.2-2.fc33                        @fedora-cisco-openh264
gstreamer1-plugins-bad-free.x86_64                 1.18.2-1.fc33                        @updates
gstreamer1-plugins-bad-freeworld.x86_64            1.18.2-1.fc33                        @rpmfusion-free-updates
gstreamer1-plugins-base.x86_64                     1.18.2-1.fc33                        @updates
gstreamer1-plugins-good.x86_64                     1.18.2-1.fc33                        @updates
gstreamer1-plugins-good-extras.x86_64              1.18.2-1.fc33                        @updates
gstreamer1-plugins-good-gtk.x86_64                 1.18.2-1.fc33                        @updates
gstreamer1-plugins-good-qt.x86_64                  1.18.2-1.fc33                        @updates
gstreamer1-plugins-ugly.x86_64                     1.18.2-1.fc33                        @rpmfusion-free-updates
gstreamer1-plugins-ugly-free.x86_64                1.18.2-1.fc33                        @updates
libnice-gstreamer1.x86_64                          0.1.17-3.fc33                        @fedora
pipewire-gstreamer.x86_64                          0.3.20-1.fc33                        @updates
python3-gstreamer1.x86_64                          1.18.2-1.fc33                        @updates

Do I miss something ? I’ll leave this topic open a few more days with the hope to get feedback from this community. If every packages I need is installed, I’ll, indeed, open a bug report.

Try to open a file over SFTP if possible.
It would be good to know whether the issue is relevant for other VFS.

1 Like

When I tried over SFTP, it suddently worked :thinking:
So I guess that, after a reboot, one of the packages I installed (see list above) fixed the problem. Unless I got a fix via an update in the meantime.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.