Top shows rngd using 100% CPU

The problem that I have is simple:

Somehow the process rngd is using 100% of the CPU (?).

There is a solution on the Red Hat Customer Portal but I don’t have a corporate Red Hat subscription.

Is there somebody here who has a Red Hat subscription? Can somebody tell me what the solution is?

I killed the process with sudo kill [pid] but when I restart the computer the process starts again and reaches 100% immediately.

You should be able to access that page with a free RHEL developer subscription.

That’s what I also thought so I registered for a free personal account.
But when I log in, go the page with the solution and refresh the page, the solution is still not visible.

I reported this problem as a bug here:

1 Like

Could you run systemctl status rngd and post the output? Do you know if rngd was explicitly enabled?

This is the output of systemctl status rngd :

rngd.service - Hardware RNG Entropy Gatherer Daemon
Loaded: loaded (/usr/lib/systemd/system/rngd.service; enabled; vendor preset: enabled)
Active: inactive (dead) since Sun 2019-08-11 14:02:07 CEST; 46s ago
Process: 934 ExecStart=/sbin/rngd -f (code=killed, signal=TERM)
Main PID: 934 (code=killed, signal=TERM)

aug 11 14:01:12 DellXPS13 systemd[1]: Started Hardware RNG Entropy Gatherer Daemon.
aug 11 14:01:12 DellXPS13 rngd[934]: Initalizing available sources
aug 11 14:01:12 DellXPS13 rngd[934]: Initalizing entropy source hwrng
aug 11 14:01:12 DellXPS13 rngd[934]: Enabling RDSEED rng support
aug 11 14:01:12 DellXPS13 rngd[934]: Initalizing entropy source rdrand
aug 11 14:02:07 DellXPS13 systemd[1]: rngd.service: Main process exited, code=killed, status=15/TERM
aug 11 14:02:07 DellXPS13 systemd[1]: rngd.service: Succeeded.

I didn’t know what the process rngd did until I ran top in order to find out what my system was doing. I didn’t explicitly enable it. I killed the process after starting up the computer. I will add the above output to the bug report on Bugzilla.

Thanks Refi64!

1 Like

Do not kill the process directly, try to restart or stop the service, test available entropy sources.

Thanks for the advice! Next time I will stop the process gently :slight_smile: !

Good news: today the problem didn’t come back!
The process rndg wasn’t started and therefore didn’t use any CPU power.

Having said that: is there someone who has a corporate Red Hat account and can tell me what the solution to the above problem is (in case the problem comes back)? I’m not sure if it is allowed to share the information though.

The issue there was that rdrand was run with a high argument to -W, but in your case it wasn’t being passed -W at all (systemctl status would have shown that).

1 Like

Thanks for reading that page for me!

Bad news: today the process was again ‘eating’ 100% of my CPU :frowning:.
So the only thing I can do right now is waiting until somebody is reading the bug report and solves the problem. Let’s wait :slight_smile:.

Out of curiosity, if you straight up disable it (systemctl disable --now rngd), does it cause any issues? Normally rngd is enabled to speed up boot do to a lack of normal RNG, but in this case it might not be needed…

1 Like

Very good idea!

I just disabled it and did a reboot twice. No issues at all!
This a very good temporary solution! It solves my problem for now!

Thanks a lot :grinning:!!

Let me know if there is anything I could do for you.

1 Like