Timeshift operation causes Fedora 37 to crash

I am running Fedora 37 on a HP desktop with a 1TB Samsung SSD 970 PRO disk and 16 Gb of RAM. This installation is about 6 months up and running with Timeshift as a snapshot backup solution from day 1.

Then last saturday the fedora GUI just freezes being about 12 minutes into a session making it totally unresponsive. I couldn’t even start up a tty session, Ctrl + Alt + F3 just didn’t work neither. Then after a lot of guesswork running clamtk to check for any virusses etc. I decided to start a new session and do some investigation in the RAM and disk usage opening 2 terminals and run the htop and iotop commands. Turns out that in the begining of the session it uses about 2 to 4 Gb of RAM for normal operations like running any systemd services and using a browser, but when Timeshift tried to remove a snapshot suddenly it consumes all of my computers memory.

Could this be a bug in Timeshift?
I removed Timeshift and this solves the problem for now. No more crashes and freezing desktop environments. However I do want to use Timeshift (or snapper if this bug or whatever continues to occur).

Six months ago I ran into the exact same issue when I thought I messed things up after running bleachbit I decided to reinstall Fedora altogether. Or could there be another factor causing Timeshift to crash my computer? I don’t keep a lot of snapshots around. This is my schedule 1 monthly, 1 weekly, 3 daily, 6 hourly and 1 at boot.

Please think with me, I am looking forward to your suggestions.

Hello, I shipped latest version If you want to test

Fedora 37 Bodhi update for latest version


Fedora 36 Bodhi update for latest version


1 Like

Thanks, but I have decided to exchange Timeshift for Snapper for the convenience of being able to boot into a snapshot from the grub menu.