Time to use a browser out of the toolbox

… and not one single layer. reset. & right now i write on chromium. thanks to toolbox. it works, no huge cpu/ram load, fast, but it works limited. youtube videos are running, sound = silence. also the text looks strange (on some pages, like “hack”). otherwise awsome.

in the terminal : a lot of ALSA lib, libpng, libGL warnings.

is it already possible to make this thing work? what else would i have to install here?

the firefox-flatpak is ok & thx, but i just can’t - you know. and the other browser-flatpak-alternatives … nope. not yet. therefore - tool … box. for now. otherwise i have to layer again.

greetings from xorg, where gnome runs like a charm & fast like nothing else on my system (+ there are plans, to improve this particular experience on 3.34 - see r/gnome). i just wish i’d known this simple workaround earlier.

edit : this had to happen, if one is exited. “toolbox list” now shows: “failed to list images with com.redhat.component=fedora-toolbox”

“podman ps” shows container id and image. also netstat, lm_sensors and chromium can be started. maybe the 3/4 - chromium - experience was to much lol.

If you want Chromium I’d recommend you layer, my best guess wrt sound is that the toolbox doesn’t expose the pulseaudio sockets by default. Text properly looks strange because you need to install separate fonts inside the toolbox.

As for the error, try running podman manually. If you see something about a permission denied error and “conmon.pid”, then take the folder that it says conmon.pid is in and run sudo chown -R $USER on it, or just reboot.

1 Like

good morning. thx @refi64 , again. i’ll play around later with it on the basis of your tips. especially the error & podman.

edit: nope. no “conmon.pid”. therefore i wanted a new start & deleted container and images. restart, again: toolbox create -> toolbox enter -> same problem as leggettc18. your

sudo chown -R $USER ~/.local/share/containers/storage/overlay-containers

saved the day. toolbox list still displays the same error message. currently, i’m replacing that with podman images -a . here, “everything is on it’s right place” (radiohead).

Maybe it is a problem with chromium. I have been running google-chrome in the toolbox and sound is working.
After suspend it some times stops working and i just run pulseaudio -k and restart google-chrome and it works again.
I use it with wayland and the text also looks normal.

really @guicgn ? that’s awsome imho. i don’t use chrome, but if chrome works (more or less) i can try it with my actual standard browser (chromium is only my secondary (now layered) browser … so fast & smooth). one can still delete really everything if errors occur. let’s see. i am excited about the upcoming “run” - outside the toolbox. and the growing flatpak - environment is just as great (+ /opt layering, if nothing else is possible). thx & welcome!

Thanks :slight_smile:
I am using the toolbox direct from git(“https://github.com/debarshiray/toolbox”). It is a different version as the one in fedora.
I managed to install everything in the toolbox, even mpv so i dont have to layer any packages.
The run command works fine too and i wrote some desktop files.
[Desktop Entry]
Name=Google Chrome
GenericName=Web Browser
Comment=Access the Internet
Exec=/home/gui/bin/toolbox run google-chrome-stable %U
StartupNotify=true
Terminal=false
Icon=/home/gui/opt/icons/google-chrome.png
Type=Application
Categories=Network;WebBrowser;

Ich just installed chromium in the toolbox and sound is working too.

1 Like

ah,

just like alex in his video. yes, i am definitely waiting for “run” & “desktop shortcuts/files” ( … and while i’m interrupting typing … and checking the other tab for the current version - the latest release - it is actually already there:

but i’m waiting for an update on sb. and then i check if my standard browser is running or not. mpv too? i prefer gnome - mpv as flatpak (with external conf under xorg, full hd -> amazing stable 1-2% cpu load), but it’s good to know what’s possible. i won’t need much in toolbox. have heaps of flatpaks, one appimage, one layered application & in the container only lm_sensors & netstat (maybe tilix will be added … no flatpak and new maintainer in sight). i’m just looking for a way to ban the layered application and start it in/out of the toolbox. so updates become faster and the ostree “free of mutations” (as far as i understand it; i’m not refi & co. .).

ps: what what, you’re running chromium without problems in the new version? and no “lib-XY”-warnings in the terminal?

I can run chromium inside the toolbox with sound. i did get some errors:
[gui@toolbox ~]$ chromium-browser
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[2169:2169:0523/211530.184371:ERROR:vaapi_wrapper.cc(327)] vaInitialize failed: unknown libva error
[2169:2169:0523/211530.287978:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.
[2133:2133:0523/211557.367463:ERROR:http_bridge.cc(126)] Not implemented reached in virtual void syncer::HttpBridgeFactory::OnSignalReceived()

I tested with youtube and it worked.
I installed toolbox with the patch from tosmi (“https://github.com/debarshiray/toolbox/pull/76”) in my home folder, so i could use the run command.
P.S. I downloaded and use this version:
https://github.com/tosmi/toolbox/blob/tosmi/exec/toolbox

thx @guicgn , much less error messages than in my case. they were almost unstoppable.

i’m waiting for 0.0.10 to land on sb - no forks, no (more) experiments (yet) ;). patience instead. i experienced this strange “failed to list images with com.redhat.component=fedora-toolbox” per “toolbox list” since the “chromium test” & i found no “conmon.pid” - folder per podman. maybe an update can fix this too. in the meantime i deleted all containers and images. something was messed up. i can wait, then again. with additional possibilities, which you already have in use. good night ( = schlaf gut).

I hope too that 0.0.10 lands soon on sb.
It would also be nice to have firefox-flatpak in flathub with H.264 without having to use the toolbox or layering for youtube videos.
Schlaf du auch gut :smiley:

… it landed?

toolbox --help

shows the “run” command now.

but i still have :

failed to list images with com.redhat.component=fedora-toolbox

even after a complete new os-installation. is this part of the current podman bug(s)? and is this hack

sudo chown -R $USER ~/.local/share/containers/storage/overlay-containers

… still necessary in the new toolbox version (no experiments for now, therefore the question)?

Check this workaround: https://docs.fedoraproject.org/en-US/fedora-silverblue/troubleshooting/#_toolbox_failed_to_list_images_with_com_redhat_componentfedora_toolbox

And yep, 0.0.10 is in the repo: https://apps.fedoraproject.org/packages/toolbox

1 Like

thx @returntrip, perfect. the reddit event with “chef-fedora” drew my attention to “cockpit”. maybe it can be tested that way. i’m throwing this “toolbox-browser thing” (only temporarily) ad acta. package layering is nothing to be ashamed of (if you don’t overdo it). mainly opt/layering works perfectly - i depend on it - currently (flatpaks grow).

nice we.