Time defaults back to UTC

Hi all,

I can’t seem to keep the time properly set to my timezone (Europe/Amsterdam). Every couple of boots it defaults back to UTC, although the timezone is still correct. I then have to turn off automatic date and time, change it, apply twice (first time I apply it gives me an error after entering my password), then turn on automatic date and time again. Any thoughts on causes and fixes?