Tigervnc can`t fullscreen on current monitor

I install tigervnc on my fedora, when I connect and login remote server,
the screen around is black,
I click F8 → options → Display → Full screen on current monitor
but nothing to change.
please help fix it, thanks.

VNC clients use software scaling only to resize the picture on the client side, but the actual screen resolution should be preconfigured in the VNC server settings like this:
I'm trying to run a remote desktop without monitor but i cannot find out how it works - #4 by vgaetera

thanks for your answer.