TianoCore - Startup | Virtual Machine Manager | Slows down the startup of a VM

Quite a long time I saw this TianoCore image while starting a VM. Somehow it looks like that the start process is very slow.

Is there a way to get rid of it while I still have it after an upgrade from F37 - 38?

Is this documented somewhere?

Newer guests apparently not need it anymore ?!

1 Like

To me that seems the bios splash screen for libvirt VMs. We see the bios splash screen with almost every machine in use.

I do not doubt about this, just not have it with every vm. And without it is a faster boot.
So I guess there was a change. Is this thing in the boot ufi partition?

You mean you have VM’s where the bios splash screen is shown longer than usual? I would define usual anything between 0.5 and 3 sec. And this is only on certain vms?

I have vm’s where the splash not shows. There it is much faster. Where it shows the splash i see that ther are two lines informing me about a EFI file …

I will post a pic …
A KDE = 22Sec boot up
A Gnome = 35 Sec boot up showing the splash, and also two efi partitions … something is wrong…

Compare hypervisor and boot settings for different VMs:

virsh dumpxml VM --xpath "/domain/@type|//os|//features"

Your command was not working out of the box. So I had dig in my requests to first fix that.

Now the output of the slow VM is :

  <type arch="x86_64" machine="pc-q35-6.2">hvm</type>
  <loader readonly="yes" secure="yes" type="pflash">/usr/share/edk2/ovmf/OVMF_CODE.secboot.fd</loader>
  <nvram template="/usr/share/edk2/ovmf/OVMF_VARS.secboot.fd">/var/lib/libvirt/qemu/nvram/fedora37_VARS.fd</nvram>
  <boot dev="hd"/>
  <vmport state="off"/>
  <smm state="on"/>

I think i do have to EFI partitions, this my causes the slowdonwn:

$ lsblk
sr0     11:0    1 1024M  0 rom  
zram0  251:0    0  3.8G  0 disk [SWAP]
vda    252:0    0   25G  0 disk 
├─vda1 252:1    0  600M  0 part /boot/efi
├─vda2 252:2    0    1G  0 part /boot
└─vda3 252:3    0 23.4G  0 part /home

That’s basically the default configuration for a VM set up with UEFI boot.
Probably your “fast” VM is not using UEFI or has Secure Boot disabled.


Isn’t that some sort of (U)EFI BIOS feature that the manufacturer’s logo keeps showing while the OS already boots? I have noted that on bare metal, and I guess it just happens on the VM as well, where Tiano Core is the UEFI firmware manufacturer.

Following that would suggest KDE is installed in legacy mode and Gnome in EFI-mode?

Difference in boot time could be something else, or just normal.

The system only knows of one. Those two VMs are separate VM, right? Not a dual-boot vm with KDE and Gnome, just to be sure.

Take a look at https://fedoraproject.org/wiki/Changes/FlickerFreeBoot.

In short, the TianoCore images is not removed until the boot process is complete. How long that takes is mainly determined by how fast your disk unit is, and also by the speed of your cpu.

On real hardware you get the image displayed by the UEFI firmware instead, but otherwise it is the same.

I ment when host ist EFI i cant use legacy and viz versa ?

I not remembered doing this on purpose. Probably just when I reinstalled in the same vm a new installation and not “gave free the unused space”.

I think there was a setting like that om GNOME boxes. I think probably if your image supports UEFI=tianocore it should also support legacy.