Thinkpad t14s AMD won't boot Fedora 33 DVD

Tried installing Fedora 33 on my new t14s AMD. Used the official Fedora 33: x86_64 DVD ISO (Fedora-Workstation-Live-x86_64-33-1.2.iso). Checked ISO for download corruption. ISO is fine. Burned it to DVD using Brasero on Ubuntu 18.04 using an external Asus USB DVD drive.

The Asus DVD drive shows up in the boot menu on the t14s. When selecting it however, the screen goes blank for about one second, and then returns to the boot menu again.

I tried the following:

  • Disabled “OS optimized defaults” in BIOS (this should disable secure boot + virtualization): no effect.
  • Tried to boot using external HDMI monitor: no effect.
  • Tried booting the official Ubuntu 20.04 image from DVD, using the same Asus DVD drive on the t14s: this boots fine.
  • Used the same Asus drive and fedora 33 DVD on another system (Intel Ivy Bridge gen): this boots fine in both BIOS and UEFI mode.
  • Checked the DVD for errors/corruption: no errors found.
  • Tried booting using a blank DVD: the screen now flashes a lot shorter than 1 second before returning to the boot menu. This means the drive appears to read something from the fedora 33 DVD, but fails.

The following conclusions can be drawn from the above:

  • DVD drive is working fine.
  • Fedora 33 DVD is booting fine on the “right” system (in both UEFI and BIOS modes).
  • t14s boots fine using this DVD drive (using Ubuntu).

I am currently at a loss. There appears to be an issue with the BIOS not being able to find the (probably) UEFI bootloader on the DVD, but this is clearly present as another system can find it without problems.

Does anyone know what the issue can be?

Also posted this question on the Lenovo/Thinkpad forums FYI.

1 Like

It’s best to create a USB media.

Also if you are using Ubuntu, you might be affected by this issue.

Yeah I’d definitely double-check to make sure secure boot is disabled.

And while this should work, it’d be useful to know if USB media works, to help isolate the problem.

1 Like