The new update of kernel and dracut deactivated some usb ports

Hi, since last update,
Some of my usb doesn’t work anymore in fedora. The generic ones work.
It’s not a problem with the ports or the devices since those 2 are working in the uefi bios.

So is it a sign that a should now update and build my bios manually with one of the generic ones ? Like described there : BIOS Modding: Introduction and Preparations - BIOS Modding Guides and Problems - Win-Raid Forum

Let’s try to describe your problem precisely before doing anything else.

Let’s say you have

  • a USB thumbdrive (“memory stick”) or external USB drive, and
  • a USB mouse.

The scenario is that both devices worked fine on any USB port of your machine (is it baremetal or virtualized?), and now after some updates (to kernel and dracut (?)), none of the two devices is working on specific USB ports of that machine?
Did I understand correctly?

1 Like

Bare metal.

It concerns every peripherals. Those USB ports are just not given any power when fedora is launching.
But as I said, those ports are working with previous kernel and in bios.
So nothing wrong with the hardWare just a plain and simple kernel problem

So this is the list of packages on the host. I’ve booted from a previous kernel and as mentionned it is working again on that kernel.

Can someone try on his hosts and see if this is something related to a brand or a more generic problem

Packages Altered:
    Install       libsbc-1.4-7.fc34.i686                                     @fedora
    Install       webrtc-audio-processing-0.3.1-6.fc34.i686                  @fedora
    Install       kernel-5.14.14-200.fc34.x86_64                             @updates
    Install       kernel-core-5.14.14-200.fc34.x86_64                        @updates
    Install       kernel-devel-5.14.14-200.fc34.x86_64                       @updates
    Install       kernel-modules-5.14.14-200.fc34.x86_64                     @updates
    Install       kernel-modules-extra-5.14.14-200.fc34.x86_64               @updates
    Install       pipewire-0.3.39-1.fc34.i686                                @updates
    Install       pipewire-libs-0.3.39-1.fc34.i686                           @updates
    Upgrade       cairomm-1.14.2-15.fc34.x86_64                              @updates
    Upgraded      cairomm-1.14.2-14.fc34.x86_64                              @@System
    Upgrade       dracut-055-5.fc34.x86_64                                   @updates
    Upgraded      dracut-055-3.fc34.x86_64                                   @@System
    Upgrade       dracut-config-rescue-055-5.fc34.x86_64                     @updates
    Upgraded      dracut-config-rescue-055-3.fc34.x86_64                     @@System
    Upgrade       dracut-live-055-5.fc34.x86_64                              @updates
    Upgraded      dracut-live-055-3.fc34.x86_64                              @@System
    Upgrade       dracut-network-055-5.fc34.x86_64                           @updates
    Upgraded      dracut-network-055-3.fc34.x86_64                           @@System
    Upgrade       dracut-squash-055-5.fc34.x86_64                            @updates
    Upgraded      dracut-squash-055-3.fc34.x86_64                            @@System
    Upgrade       gnome-shell-40.5-2.fc34.x86_64                             @updates
    Upgraded      gnome-shell-40.4-1.fc34.x86_64                             @@System
    Upgrade       ibus-m17n-1.4.8-1.fc34.x86_64                              @updates
    Upgraded      ibus-m17n-1.4.7-1.fc34.x86_64                              @@System
    Upgrade       lutris-                               @updates
    Upgraded      lutris-0.5.9-1.fc34.x86_64                                 @@System
    Upgrade       osinfo-db-20211013-1.fc34.noarch                           @updates
    Upgraded      osinfo-db-20210809-1.fc34.noarch                           @@System
    Upgrade       php-7.4.25-1.fc34.x86_64                                   @updates
    Upgraded      php-7.4.24-1.fc34.x86_64                                   @@System
    Upgrade       php-cli-7.4.25-1.fc34.x86_64                               @updates
    Upgraded      php-cli-7.4.24-1.fc34.x86_64                               @@System
    Upgrade       php-common-7.4.25-1.fc34.x86_64                            @updates
    Upgraded      php-common-7.4.24-1.fc34.x86_64                            @@System
    Upgrade       php-fpm-7.4.25-1.fc34.x86_64                               @updates
    Upgraded      php-fpm-7.4.24-1.fc34.x86_64                               @@System
    Upgrade       php-json-7.4.25-1.fc34.x86_64                              @updates
    Upgraded      php-json-7.4.24-1.fc34.x86_64                              @@System
    Upgrade       php-mbstring-7.4.25-1.fc34.x86_64                          @updates
    Upgraded      php-mbstring-7.4.24-1.fc34.x86_64                          @@System
    Upgrade       php-opcache-7.4.25-1.fc34.x86_64                           @updates
    Upgraded      php-opcache-7.4.24-1.fc34.x86_64                           @@System
    Upgrade       php-pdo-7.4.25-1.fc34.x86_64                               @updates
    Upgraded      php-pdo-7.4.24-1.fc34.x86_64                               @@System
    Upgrade       php-sodium-7.4.25-1.fc34.x86_64                            @updates
    Upgraded      php-sodium-7.4.24-1.fc34.x86_64                            @@System
    Upgrade       php-xml-7.4.25-1.fc34.x86_64                               @updates
    Upgraded      php-xml-7.4.24-1.fc34.x86_64                               @@System
    Upgrade       podman-3:3.4.1-1.fc34.x86_64                               @updates
    Upgraded      podman-3:3.4.0-1.fc34.x86_64                               @@System
    Upgrade       podman-docker-3:3.4.1-1.fc34.noarch                        @updates
    Upgraded      podman-docker-3:3.4.0-1.fc34.noarch                        @@System
    Upgrade       podman-gvproxy-3:3.4.1-1.fc34.x86_64                       @updates
    Upgraded      podman-gvproxy-3:3.4.0-1.fc34.x86_64                       @@System
    Upgrade       podman-plugins-3:3.4.1-1.fc34.x86_64                       @updates
    Upgraded      podman-plugins-3:3.4.0-1.fc34.x86_64                       @@System
    Upgrade       spice-vdagent-0.21.0-4.fc34.x86_64                         @updates
    Upgraded      spice-vdagent-0.21.0-3.fc34.x86_64                         @@System
    Reason Change 1password-8.3.0-1.x86_64                                   @1password
    Removed       kernel-5.14.11-200.fc34.x86_64                             @@System
    Removed       kernel-core-5.14.11-200.fc34.x86_64                        @@System
    Removed       kernel-devel-5.14.11-200.fc34.x86_64                       @@System
    Removed       kernel-modules-5.14.11-200.fc34.x86_64                     @@System
    Removed       kernel-modules-extra-5.14.11-200.fc34.x86_64               @@System
    Removed       kmod-nvidia-5.14.11-200.fc34.x86_64-3:470.74-1.fc34.x86_64 @@System

I see that finally I m not the only one


Kernel 5.14.14-200 disables USB on boot. My device has a USB breakout for display and network and only USB input support so it’s not possible for me to collect any details on the failed boot. Switching back to the previous kernel for now.

Still the same problem with new update kernel 5.14.15

I’m actually afraid of even upgrade to fc35 if i m not able to have my usb hub back

Apparently we will get a fix in version 16

And this commit seems indeed the problem

Still not working with 5.14.16

1 Like