Tethering from TracFone phone

I want to tether my laptop running Fedora Linux 38 (Workstation Edition) to my TracFone cell phone, a TracFone Alcatel A406DL phone (a flip phone), which has paid-up data airtime available for me on it. I don’t have home Internet service (and Starlink is too expensive).

I asked TracFone at their forum (TracFone Wireless Forums • View topic - problem tethering). TracFone used to forbid tethering but now allows it in its legal terms and the phone includes a setting for tethering. I asked about this in TracFone’s forum, but no one answered.

In my phone,

Settings > Network & Connectivity > Mobile network & Data > Data Connection > On,

Settings > Network & Connectivity > Mobile network & Data > Wi-Fi > Off,

and a data cable connecting the phone to a USB port on the laptop,

then Settings > Network & Connectivity > Internet Sharing > USB Tethering > On,

and with the phone’s browser when opened showing Web content, albeit limited to one website that I apparently can’t change, the Web content it’s showing being up to date (e.g., in news headlines),

I don’t seem to be getting access to the Internet in my laptop’s browser. My laptop evidently sees something coming from the phone, and my phone consumed about 10 MB of paid-for data, but my laptop did not see enough to give me Web access.

On my laptop:

Settings > Mobile Network > Network > Mobile Data > (slider blue = on).

Settings > Mobile Network > Network > Data Roaming > (slider blue = on).

Settings > Mobile Network > Network > Network Mode > 2G, 3G (if I try “2G, 3G (Preferred)” I eventually get a temporary popup saying “The given combination of allowed and preferred modes is not supported”, or I get it immediately if while waiting I click Set) (the only other choices are “3G Only” and “2G Only” & I haven’t had a better outcome by setting to either of the latter).

Settings > Mobile Network > Network > Network > Automatic > (slider gray = off) yielding Choose Network which yields “Timeout was reached” in a temporary popup, yielding restoration of Automatic with slider blue = on.

Settings > Mobile Network > Network > Advanced > Access Point Names yields a dialog listing 4 Access Points, all of which are named Default, 2 of which have APN “att.mvno” (the phone likely uses Verizon and not AT&T as the nonvirtual carrier) & 2 of which have APN “tfdata” (I’ll speculate with only flimsy proof that “tf” stands for TracFone), and none of the 4 of which have entries for Username or Password.

Settings > Mobile Network > Network > Advanced > SIM Lock > Disabled.

Settings > Mobile Network > Network > Advanced > Modem Details > Modem Status > Carrier (blank), Network Type: “unknown”, Signal Strength: 40% (that’s usual but sometimes it has said 100% and sometimes it spontaneously changed), & Network Status: Searching; Device Details are here omitted.

Settings > Network > Configuration > Automatic.

Settings > Network > PCI Ethernet > Cable unplugged.

Settings > Network > USB Ethernet > Connected.

Settings > Network > VPN > Not set up.

Settings > Network > Proxy > Configuration > Automatic > Configuration URL (Configuration URL not provided).

Settings > Wi-Fi > (slider gray = off) > vertical-3-dot menu > Saved Networks > Saved Wi-Fi Networks dialog (listing nothing recognized as coming from the phone).

Settings > Wi-Fi > (slider gray = off) > vertical-3-dot menu > Turn On Wi-Fi Hotspot… > Turn On Wi-Fi Hotspot? > Network Name set to tmp-try & Password set to aaaaaaaa (I won’t keep this if I can figure out how to delete the network from the list) then Turn On.

Settings > Wi-Fi > (slider blue = on) > vertical-3-dot menu > Connect to Hidden Network… > dialog > Wi-Fi security > (all options failed, whether the password failing, asking for details I didn’t know, or doing nothing).

Settings > Wi-Fi > Airplane Mode > (slider blue = on).

Settings > Wi-Fi > (slider blue = on) > vertical-3-dot menu > Turn On Wi-Fi Hotspot… > Wi-Fi Hotspot Active & displaying a QR code “to connect” (with Network Name, Security type (WPA), and Password all shown & not editable and 2 or 3 are correct (I assume WPA is correct)); then I used the cell to photograph the QR code at High Resolution (the phone does not recognize QR codes); I saw no evidence of connecting.

In Terminal, lsusb, when the phone via the data cable is connected to either the right-side port directly or to the left-side port through a hub, output is identical except as follows (the phone is not a Google phone, but uses KaiOS as its OS) (being identical includes that Bus 002 is completely identical):

via rt-side port:

Bus 001 Device 008: ID 05e3:0610 Genesys Logic, Inc. Hub

Bus 001 Device 011: ID 05c6:f00e Qualcomm, Inc. FP3

via hub at left-side port:

Bus 001 Device 012: ID 18d1:4ee1 Google Inc. Nexus/Pixel Device (MTP)

Bus 001 Device 008: ID 05e3:0610 Genesys Logic, Inc. Hub

Thus:

via rt-side port (the lapotp has 2 built-in USB ports):

Bus 001 Device 011 is present & Bus 001 Device 012 is not

Bus 001 Device 011 follows Bus 001 Device 008 & there’s no Bus 001 Device 012

via hub at left-side port (the hub plugged into 1 port provides 4 ports & this testing is on a frequently-used port of the 4):

Bus 001 Device 012 is present & Bus 001 Device 011 is not

Bus 001 Device 012 precedes Bus 001 Device 008 & there’s no Bus 001 Device 011

When I got this lsusb output and was trying tethering, my phone used few or no data MB. The phone said 11.37GB before and after, so consumption had to have been 10MB or less, probably 5MB or less, maybe zero.

From time to time, a temporary popup says “Network Connection”/“Activation of network connection failed”. I don’t think I’ve ever seen an icon show that a network was even briefly available.

In the window’s main desktop’s top panel (from Gnome 44.3), near the right end, where the icon for Wi-Fi reception usually shows, there’s a question-mark icon.

I pointed my laptop’s Firefox 116.0.3 (64-bit) browser to example.com but over 10 minutes later the effort was still pending, not downloading (the tab still said New Tab and the tab’s progress dot was still moving) but not denying that it can connect, the browser’s page being blank and its source code yielding only what’s at view-source:chrome://browser/content/blanktab.html . Over 15 minutes after starting, the browser said this: “The connection has timed out”/“The server at example.com is taking too long to respond.”/“. . . The site could be temporarily unavailable or too busy. Try again in a few moments.”/“. . . If you are unable to load any pages, check your computer’s network connection.”/“. . . If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the web.” Firefox, when I use other networks, accesses the Web, but not this time.

(All spaceless suspension points are so in originals; all spaced ellipses are mine.)

This is at my physical home. The phone does not normally use Wi-Fi. If I try to get Internet access at my laptop through Wi-Fi and not my phone, I can see networks, but all of them require authentication (likely a password) and they’re not mine. Outside of my home, I’ve successfully used 3 networks that don’t need authentication and failed with none. My phone is not set up to require authentication for any function; I use it without a password or a PIN.

What might I be doing wrong at my laptop in trying to tether?

Thank you.

  • If any VPN client is running on the mobile, stop it.
  • Enable USB tethering on the mobile and connect it to Fedora with a USB cable.
  • Configure an automatic Ethernet connection on Fedora, i.e. DHCP and DHCPv6/SLAAC.
  • Check your active connections, IPv4 and IPv6 connectivity, DNS status:
nmcli general status; nmcli connection show
resolvectl status --no-pager
resolvectl query example.org --no-pager
ping -c 3 8.8.8.8
ping -c 3 2001:4860:4860::8888
nslookup example.org 8.8.8.8
nslookup example.org 2001:4860:4860::8888