Tap-and-drag Flatpak only

This is something I’ve found on Fedora 38, both the normal Workstation and Silverblue.
I can disable tap-and-drag:

% gsettings get org.gnome.desktop.peripherals.touchpad tap-and-drag                                                                  

…but this is effective for everything except applications install via Flatpak. Would anyone be able to suggest how I might also disable tap-and-drag for Flatpak apps, please?

flatpak run org.freedesktop.Platform

gives you a shell in which you can change the flatpak runtime’s settings.
I’m not 100% sure whether they are per app, though - if they are then you could instead start your flatpak app and enter its sandbox via

flatpak enter IDofYourApp bash

and change settings there, hoping they stick.

Thanks - useful to know about accessing the app’s environment that way.
No luck so far, though:

% flatpak enter com.microsoft.EdgeDev bash
bash-5.1$ gsettings set org.gnome.desktop.peripherals.touchpad tap-and-drag false
bash-5.1$ gsettings get org.gnome.desktop.peripherals.touchpad tap-and-drag

I wonder what caused this behaviour to change in F38 - tap-and-drag could be disabled for everything in F37.

So the settings are kept, but they are not applied (i.e. tap-and-drag is still active even though set to false both outside the flatpak and inside)? Have you tried with the runtime (platform) setting?

I got two options for the platform:

Similar installed refs found for ‘org.freedesktop.Platform’:

   1) runtime/org.freedesktop.Platform/x86_64/21.08 (system)
   2) runtime/org.freedesktop.Platform/x86_64/22.08 (system)

I tried the gsettings command with each. Changing it has no effect and the changed setting doesn’t persist exiting and re-entering the runtime.

The settings change does appear to persist for a specific application, though not if I reboot.