Talk: On-screen keyboard fails to open automatically in KDE on a touch device

This is a discussion topic for the following Common Issue:

You can discuss the problem and its solutions here, but please note that debugging and technical feedback should primarily go to the issue trackers (e.g. Bugzilla) linked in the Common Issue, because that’s the place that developers watch, not here.

If there are any updates/changes/amendments for the Common Issue description, which you believe should be performed, please post it here.

Please see the Common Issue for solution/workarounds:

Hmm, so I tried this today and I don’t seem to be able to reproduce it. Let’s take it step by step.

  1. I installed a clean F38 KDE into a virtual machine and fully updated it.
  2. On first login, there seems to be no accessibility menu that would allow me to trigger a virtual keyboard.
  3. After logging in, I can go to System Settings → Accessibility, there’s no virtual keyboard either.
  4. But I can go to System Settings → Input devices → Virtual Keyboard, and there’s None (default) and Maliit.
  5. If I enable Maliit, nothing happens. I don’t get a virtual keyboard when I click into a text field (Plasma, KWrite, etc).
  6. I create ~/.config/plasma-workspace/env/ as instructed in your workaround, reboot.
  7. On login screen, there’s still no option to invoke a virtual keyboard, nor it pops up automatically (which makes sense, the workaround was done just for the user session).
  8. After logging in, the virtual keyboard still doesn’t pop up in text fields (Plasma, KWrite). I have no idea how to trigger it. In Plasma bottom right corner, there’s Input Method icon, but after clicking on it, it just says “On screen keyboard deactivated” (or “activated” when I click again), nothing happens.

I’m confused. First of all, why is the virtual keyboard not working at all? And second, what is your target use case? How does it help you to have a virtual keyboard in the user session when the login screen seems to have no support for it? Do you use it as an accessibility option or only when running KDE on a mobile device?

Numbers refer to your points above:

  1. :+1:
  2. It’s a bit weird - the UI isn’t consistent between the initial sddm login, and unlocking the lockscreen. There is no keyboard shortcut for the initial login, but if you’re on a touchscreen enabled device and touch the password input the Maliit keyboard pops up and works fine (regardless of enabling Maliit in KDE settings)
  3. See 4.
  4. What you did here is correct. I just added the accessibility tag because gnome users would see the virtual keyboard under accessibility. Maybe I should just remove that tag.
  5. If memory serves, there is an option to click on the virtual keyboard in the system tray after Maliit is enabled.
  6. :+1:
  7. Same as login before temp fix - no keyboard toggle is present, it is only activated by touch input, but it does work as intended without configuration
  8. Maliit doesn’t automatically pop up from mouse clicks - only via touch screen input. It sounds like the toggle you’re hitting is enabling touch input / then disabling it. If you don’t have a touchscreen, I’m not sure if there is a way to simulate?

To summarize - keyboard isn’t working at all because you need touch input enabled to use virtual keyboard on initial sddm login. After you enable Maliit in settings initially (without the workaround), you need to toggle the keyboard in the system tray like you did after applying the workaround. It’s speculation on my part, but I suspect the workaround prevents the keyboard from entering x11 mode. The toggle only causes the keyboard to pop up on the screen in that mode.

I primarily use the touch keyboard for plasma mobile. I was able to replace windows on my surface tablet, and currently use plasma mobile as my daily driver. Before using the workaround, that wasn’t tenable (initial login does in fact work - the Maliit pops up only when using a touch screen). That said, It’s a nice accessibility option if I was using my laptop and had an issue with the physical keyboard, or something like that.

Hello. I’m hoping to be able to use the virtual keyboard on a 2-1 laptop, but as a novice I’m unfortunately lost by the instructions in the workaround (beginning at “populate it with the following…”). I think I’ll remain patient that the bug will be fixed. I take it that there are no working alternatives to “maliit” for someone wishing to use a virtual keyboard with KDE?

@dwise I believe in you! I made a step by step video - let me know if you still have issues:

@kparal ^^ Since you weren’t testing on a touch device, you might also find this helpful.

Thanks for the helpful video @belsar. Your belief was justified, after a bit of a cliffhanger. The first time I tried following the instructions and restarting, my computer wouldn’t boot.

I deleted the txt file using a live USB and started over. I went through the video again and it turned out I hadn’t typed “#!” in front of “/bin/bash”.

Now I’m happy to be posting this message in full tablet mode using the virtual keyboard.

@belsar Sorry for a long delay. Your response and especially the video guide makes it very clear now. I haven’t realized that a touchscreen is necessary to trigger the virtual keyboard. I adjusted the problem description a bit, and I’ll make it official. Thanks a lot for your work!

1 Like