System policy prevents changes. Contact your system administrator

I had this issue with GNOME on FW 30. Installed FW 31 hoping it would be solved. I am attempting to run FW 31 headless, using VNC/XRDP (doesn’t matter which one) to connect. Standing in front of the monitor physically attached to the box, the “UNLOCK” icon works as expected. When connected using VNC or XRDP, the “UNLOCK” is greyed out and generates “System policy prevents changes. Contact your system administrator.” when hovered over. I am the only user on the box, UID=1000; a member of the “wheel” group. Somehow when the X server starts, the USER does not have sufficient rights to make “NORMAL” system changes. This is somehow related to GNOME, but I haven’t figured out how yet.

Anyone have ideas? The real disaster in all this is that it is not possible to install Android Studio remotely. There are many other issues as well.


Hello @timber,
I believe that GDM is preventing you from getting access remotely. Perhaps this link will help, though dated a bit, it seems applicable. Also from Redhat here. Hope that helps!

Hi jakfrost,
I appreciate the guidance! I knew it wasn’t selinux (I disabled it as a test), nor the firewall (disabled it also as a test). I had just begun spelunking GDM moments before your reply, and knew I was headed in the right direction. Because the post is so old, many of the components have changed, but will persevere.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.