System freezes while upgrading Fedora 31 => 32

I keep having problems upgrading from Fedora 31 to 32. dnf system-upgrade download --releasever=32 goes fine, but then when I do the upgrade-reboot, it always freezes up about 1/4 to 1/3 of the way through the upgrade process. The system ends up unbootable and I have to restore the drive from a backup image. I used F11 to switch to console to see where exactly it goes wrong. Several times the cursor simply stopped flashing and the system becomes unresponsive; another time the keyboard buttons worked, but the upgrade process was stopped and showing a “soft lockup” message that kept repeating every few minutes like in the picture. It stops at different packages.

I get these lockups or full-out system freezes occasionally in normal OS operation, maybe once a week or so. I’ve searched the web and I’ve found a discussion where someone blamed it on nouveau and installed xorg-x11-drv-nvidia, but when I did that and restarted the PC, it would freeze at boot, so I had to restore the image again.

FWIW I have a NVIDIA card, use X11 and appear to be using nouveau. Several years ago I had GPU problems and had to switch from nouveau to nvidia or the other way around (don’t remember). I also repartitioned the drive to GPT with EFI partition a year or two ago and got Fedora to boot again without reinstalling it. This was all long before the last successful upgrade (F30 => F31) about 6 months ago.

If it matters, the upgrade process needed about 7 GB free space, and I made 10 GB, but the last 3.5 GB was by deleting /var/cache/abrt-di

1 Like

You can boot a Fedora live session, mount your partitions and force the upgrade.

If the issue persists, force file system check, perform memory test, check disk SMART info.

1 Like

Thanks, totally forgot chrooting is a thing, hehe. I did it per instructions (mount Fedora and EFI partitions, bind the dirs and then dnf --installroot=...), looks like it worked.

I left the live DVD overnight to complete the distrosync, found it in the morning frozen with screen off (nouveau/nvidia hell I presume), but after I restarted it and redid the procedure, distro-sync reported nothing more to do, so I’m chalking this up as a win :smiley:

edit: ugh some more oxygen icons have disappeared. Why does this keep happening on every upgrade… :angry:

edit 2: Also, when mounting in Dolphin, PolicyKit1 now asks for root password. Inputting my own password doesn’t work. I don’t think I’ve ever used a root password. I’m able to mount normally with sudo in the terminal.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.