System crashes when trying to update. Shell level is hight and RAM usage increases exponentially

I have a relatively new installation of Fedora. I’ve been using it for about a week already.

Since yesterday I have a problem when trying to update y system. I tried to do it as usual with the Software Centre. Installed the updates but didn’t reboot instantlly. About 2 hours passed and suddenly there were more packages that had to be updated so I clicked install and restart.

When I did that, the computer rebooted but apparently the updates were never applied since the screen of “Installing updates” just lasted less than 2 second and the progress bar never got to the end.

Then I tried updating via Terminal with sudo dnf update but this message of shell level is too highg (1000) pops up on terminal and I have to Ctrl+C the PC so it doesn’t crash completely.

When I monitor the process with the System monitor, I can see the RAM usage increases constantly until y Ctrl+C.

I don’t know what I could do to fix this.

PS: Since my computer os a MacBook I was trying to install all drivers properly to make my FaceTime HD web cam work but had relative succes (it doesn’t work on Cheese or webcam apps but it works “fine” on Jitsi or Zoom). I don’t know if it had something to do with it.

A few more INFO.

I’m using Fedora 38 and apparently there is some problem with dnf. Everytime I type “dnf” and whatever comes next, this bug happens.

The “shell level is too high (1000)” shows up.

Tried (in chronological order these commands:

“sudo -i” & “dnf update --refresh” but the same error happened.

The packages being updated are kaaccounts, kdegraphics, mesa, python3 AND xxhash-libs.

I was told to try and update each package individually but it didn’t work.

As I got into the matrix Fedora chat, someone told me that perhaps it’s an error in a line in .bashrc but then other user said it’s probably not that since it’s just for this update.

The list of packages installed doesn’t appear in the Terminal but I know what are them because of the Software Center interface.

I tried with “dnf upgrade --verbose” but nothing happend. The same error of no output and increase in RAM usage happens again.

“dnf clean all” didn’t work. Same bug.

Even with just dnf --help the system was about to collapse.

When I typed “which dnf” the output was “/usr/bin/dnf”.

Python works when I type python3.

When I typed “rpm -q dnf” only one version showed up: dnf-4.16.1-1.fc38.noarch.

Try reinstalling dnf from a live ISO. First mount your real installation to /mnt, then run sudo dnf --installroot=/mnt reinstall dnf

That I should do it by typing
sudo mount /dev/mapper/luks-1a765d43-14c6-44a5-994f-5cfc0f446a1b /mnt

I’m new to these codes.


For those that are new as me. Run lsblk or sudo fdisk -l to identify the partition of your installation.

Better if one uses lsblk -f to see the UUIDs and file systems type as well.

This looks like your user is not part of the wheel group. Please ensure that your user is part of the wheel group before you try to modify your DNF installation as it may not be the problem at all, if your user is not a part of the wheel group (which gives sudo permission levels expected).

According to this:

Shell Level identifies the level of sub-shell in a nested shell

This probably explains the high memory usage, apparently you have way too many nested shells, do you have any type non default configuration in your .bashrc? Do this clean install have a clean, new home directory?