System abruptly reboots after a few hours


my fedora38 restarts abruptly after a few minutes or hours.

no particular information in “journalctl” just before the boot message.

sudo journalctl --reverse 

mai 20 12:00:17 legion kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
mai 20 12:00:17 legion kernel: Command line: BOOT_IMAGE=(hd1,gpt2)/vmlinuz-6.2.15-300.fc38.x86_64 root=UUID=6b75a>
mai 20 12:00:17 legion kernel: Linux version 6.2.15-300.fc38.x86_64 (mockbuild@9ce97d1fde5043c6a5e6af84f9091fb1) >
-- Boot 9824ab0423404d42ba00fb51583deffb --
mai 20 11:52:39 legion kernel: perf: interrupt took too long (2514 > 2500), lowering kernel.perf_event_max_sample>
mai 20 11:48:12 legion kernel: Bluetooth: hci0: ACL packet for unknown connection handle 3837
mai 20 11:31:38 legion kernel: Bluetooth: hci0: ACL packet for unknown connection handle 3837
mai 20 11:21:07 legion kernel: Bluetooth: hci0: ACL packet for unknown connection handle 3837
mai 20 11:18:33 legion kernel: Bluetooth: hci0: ACL packet for unknown connection handle 3837

With dmesg, I only have msg from the last boot (so nothin which could explain the reboot)

I searched in /var/log for files that might contain information about this period (12:00) but I didn’t find anything relevant.

Does anyone know in which log files I could find traces ?

NB: this computer works in a dual boot with windows 10. And no restart with windows.

an extract of my config :

  Kernel: 6.2.15-300.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.1 tk: GTK v: 3.24.37 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
  Type: Laptop System: LENOVO product: 82JU v: Legion 5 15ACH6H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 15ACH6H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    UEFI: LENOVO v: GKCN59WW date: 11/21/2022
  ID-1: BAT0 charge: 80.2 Wh (98.0%) condition: 81.8/80.0 Wh (102.3%)
    volts: 16.6 min: 15.4 model: Celxpert L20C4PC1 serial: <filter> status: full
  Info: 8-core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 1445 high: 3200 min/max: 1200/4462 boost: enabled cores:
    1: 1200 2: 1200 3: 1200 4: 1577 5: 2444 6: 3200 7: 1200 8: 1462 9: 1247
    10: 1200 11: 1200 12: 1200 13: 1200 14: 1200 15: 1200 16: 1200
    bogomips: 102206
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 530.41.03 arch: Ampere pcie: speed: 2.5 GT/s lanes: 8
    ports: active: none off: DP-2,HDMI-A-1 empty: DP-1,eDP-2 bus-ID: 01:00.0
    chip-ID: 10de:24dd
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 pcie: speed: 8 GT/s
    lanes: 16 ports: active: none off: eDP-1 empty: none bus-ID: 06:00.0
    chip-ID: 1002:1638 temp: 37.0 C
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:3 chip-ID: 04f2:b725
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: gpu: amdgpu,nvidia,nvidia-nvswitch
    display-ID: 0
  Monitor-1: DP-2 model: BenQ EW3270U res: 3840x2160 dpi: 140
    diag: 801mm (31.5")
  Monitor-2: HDMI-A-1 model: BenQ EW3270U res: 3840x2160 dpi: 140
    diag: 801mm (31.5")
  Monitor-3: eDP-1 model: BOE Display 0x0a1c res: 1920x1080 dpi: 142
    diag: 395mm (15.5")
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon Graphics (renoir LLVM
    16.0.1 DRM 3.49 6.2.15-300.fc38.x86_64) direct-render: Yes

Thanks in advance for your replies

1 Like

Start by checking for a hardware issue:

Note that Windows may avoid using some hardware features that a device does not implement correctly. Newer linux versions may add support for new or advanced device capabilities, but may need driver options to solve problems with specific devices.

Dell provides Windows tools to check system health — Lenovo may have something similar. You should run memtest86+ and also monitor temperature sensors.

Try to remove all non-essential devices in case a device/driver combination is dis-functional. Graphics and network hardware may not be removable, in which case you may have to rely on vendor forums. It is often helpful to have USB network adapters and input devices (mouse, keyboard) that have been tested on another linux system.

One additional tool that might assist, particularly if the issue is temps, would be to install lm_sensors and gkrellm. lm_sensors monitors the various sensors and gkrellm provides a near real-time graphical display of the outputs, including configured temps, cpu activity, disk & network activity, and more.

While the temps are not instantaneous in display the numbers can tell you the basic facts.

I had one system that I was using an AIO water cooler on the cpu with average temps around 50C. It suddenly started unexplained shutdowns and I found the cause was failure of the pump in the cpu cooler so the cpu forced a shutdown with a temp spike of 100C. My newer cooler has a sensor that is connected to one of the fan connectors on the mobo and I can now monitor the pump as fan speed for that purpose.

My meaning is that there are several tools that can be used to analyze the cause, and cpu temps will cause sudden shutdowns that are not logged anywhere – it just appears almost as if one switched off the power.

1 Like

This probably indicates that your Lenovo is not one of the Fedora certified ones? So a comparison between W10 and F37/38 is quite out of range. As already mentioned Linux probably checks different variables to protect the device and a reboot might be a protection. And that is probably also the reason why Lenovo not certified their gamer laptops for fedora til now.

I do live in a very humid climate. If we not use the computers day and night the possibility that we do have corrosion is big. First I would do is, to take memory out and clean with an electrical contact cleaning spray. Also the sockets.

I do not like to make advertisements for Nobara the Gamers Distro where is fedora based. But in your case you probably also find more specific solutions with more speciffic kernel patches to avoid issus you have.

And if in case you already com from there with a patched fedora, please do not expect to much support here, we are completely incompatible.

Thanks a lot for your replies.

I checked the temperatures, and everything seems OK.

I don’t think it was a LENOVO compatibility problem, because I’ve been using this laptop since the FC37 version, without any major problem. The problems appeared since the update to F38.

A few hours after posting my request, I ran a “dnf update” which updated many FIRMWARE packages.
Since this update, the system does not seem to reboot any more.

I will keep you informed in 2 or 3 days if the problem is solved.

Thanks again for your help.


It seems possible that the newer kernels in F38 with your hardware were struggling with compatibility and the older firmware. Specifically which firmware is in use can be seen by perusing the output of dmesg and/or journalctl -b. Doing so may give you an idea of where changes may have occurred for future reference.

1 Like