Sysctl can't auto reload net.bridge.bridge-nf-call options on Fedora38 reboot

sysctl can’t auto reload /etc/sysctl.d/99-bridge.conf on Fedora operating system
net.bridge.bridge-nf-call-arptables = 0
net.bridge.bridge-nf-call-ip6tables = 0
net.bridge.bridge-nf-call-iptables = 0

and all i can do manual run sysctl -p /etc/sysctl.d/99-bridge.conf when Fedora booted
it troubled me for a long time , Does anyone have this problem and have resolved it?

Hello @shaojing ,
Welcome to :fedora: !
You should be using systemd for services on your system with Fedora, not really sysctl. So the command is systemctl for systemd.

Well sysctl is nothing to do with services and can’t generally speaking be replaced with systemctl so that suggestion doesn’t make a huge amount of sense.

In fact systemd is what takes care of applying sysctl.d settings via the systemd-sysctl.service unit.

I suspect the messages the poster saw are harmless and are a result of the settings being loaded early, before the bridge had been created when the kernel did not yet recognise those settings but they should have been applied again automatically once the bridge showed up.

1 Like

Thanks for clarifying this, my mistake.

Actually looking at sysctl.d(5) it looks like net.bridge settings are not currently treated as network settings that need to be applied once it shows up.

That manual page does suggest as a general rule that settings which need to be applied once something has loaded are better done via udev rules though.

In fact it’s exactly these settings which are used as an example and it shows several different ways to deal with them.