Switcheroo-control option not showing in Silverblue 38/39

I’m using a hybrid Nvidia card on my Silverblue 38. For some reason, right clicking application does not show the GPU switch option, but DRI_PRIME=1 from terminal is working fine. Switcheroo-control used to show up in the past but stopped showing after an update.

Edit: Upgraded to Silverblue 39 and the problem still existed.

What’s your rpm-ostree status? On which version did it work and which does it not work anymore?

dadstick@fedora:~$ rpm-ostree status
State: idle
Deployments:
● fedora:fedora/39/x86_64/silverblue
                  Version: 39.20231027.n.0 (2023-10-27T08:06:27Z)
               BaseCommit: 081d19ba43657c07931e56dce115549ee933108225eebe4266d09db1ff1782f6
             GPGSignature: Valid signature by E8F23996F23218640CB44CBE75CF5AC418B8E74C
          LayeredPackages: akmod-nvidia distrobox gnome-tweaks steam-devices supergfxctl
                           xorg-x11-drv-nvidia-cuda

  fedora:fedora/39/x86_64/silverblue
                  Version: 39.20231026.n.0 (2023-10-26T08:07:18Z)
               BaseCommit: 8f71450be51173e5a36d776ee40126457736867b9052b629cb60f39c326bf0e4
             GPGSignature: Valid signature by E8F23996F23218640CB44CBE75CF5AC418B8E74C
          LayeredPackages: akmod-nvidia distrobox gnome-tweaks steam-devices supergfxctl
                           xorg-x11-drv-nvidia-cuda

Upgraded to Silverblue 39 and the problem still existed. Sorry I don’t remember which one was the last working version.