Switch to the kernel-16k variant

As of today, we’re switching the default kernel package for Fedora Asahi Remix to kernel-16k. The existing kernel package will become a 4k page-size variant when we update to 6.5, and is not recommended for general usage at this point. This change keeps the Remix close to upstream Fedora, where we recently introduced 16k-flavored builds.

Installs made with today’s build (202308191708) or later will use kernel-16k by default; to convert existing systems that were installed from older builds, run:

$ sudo sed -i s/kernel-core/kernel-16k-core/ /etc/sysconfig/kernel
$ sudo dnf install -y kernel-16k kernel-16k-modules-extra

The reboot the system and run sudo dnf remove -y kernel-core to remove the old kernel packages. You can confirm you’re running the correct kernel with uname -r, which should show a version string ending with aarch64+16k.


For those of us who have no /etc/sysconfig/kernel:


Source: @dcavalca on Matrix


latest kernel update (vmlinuz-6.4.11-401.asahi.fc38.aarch64+16k) has broken video acceleration (cursor movement and typing is super slow and fractional scaling in sway is very grainy)

p.s. okay so apparently i needed to upgrade mesa from @asahi/mesa copr

Yes, this latest update is tightly coupled with mesa (this isn’t normally the case but it happens sometimes).

What does this mean exactly? Is a dnf update good enough? I’m seeing rendering issues in Chromium that I think are caused by this (turning off hardware acceleration in chromium settings fixes it)

i’m not sure tbh, sorry. i did sudo dnf copr enable @asahi/mesa fedora-38-aarch64 and dnf upgrade, but then it told me that i have two identical repos so i had to remove one, so i’m no longer sure if adding the copr was necessary

Yes, dnf upgrade is good enough (that’s what I did to upgrade the kernel and matching mesa simultaneously).

Interestingly enough, I did have the same issue with Chromium you described right after that upgrade. I just removed my .config/chromium/ directory to fix it, so I’m not sure it’s related to hardware acceleration since that’s the default and enabled in my working Chromium config (perhaps try enabling hardware acceleration again in Chromium and see if it’s OK?).

Thanks, I had to rm -rf ~/.config/chromium to fix it too :man_shrugging:

Chrome/Chromium/Electron and related apps have a bug where they don’t manage the GPU shader cache properly, so Mesa updates often break them. You have to delete ~/.config/chromium/Default/GPUCache (or similar depending on the app) to fix it. Upstream bug.