Sway - need help running Plasma apps


So the story is I have Plasma spin installed and configured. I wanted to try sway and installed it. It’s all ok except:

  1. When trying to run any Plasma app it gets some weird look completely not inline with the theme I have chosen in Plasma.
  2. Trying to run Neochat or Tokodon (configured properly in Plasma) it seems like don’t read any of the config files present in my home dir.

Maybe someone more experienced with sway could help me with overcoming these problems ?
Or just tell me “not possible” if that’s the case.

So you had a Fedora KDE install and installed Sway on top of it, same user profile, and in SDDM you choose sway instead of Plasma?

Or do you use another user account?

Yes, I installed sway on top, same user profile and I choose sway in sddm.

OK, so number 2 solved. Apps like Tokodon and Neochat keep their secrets in kwallet. Since it’s not available for sway then the apps are not working.

Deleting app configs in $HOME and reconnecting to services worked flawlessly.

Interestingly - even though I deleted all the config data, after reconfiguring the apps, they start with a proper Plasma theme. Dolphin does not.


Number 1 also solved with using qt5ct package. If anyone is interested I can give more detailed guide here.