Suspend fails, unreliable, freezes - F31


  • suspend (closing lid) is unreliable with kernel 5.3.7, vanilla XFCE fresh install. Sometimes (details below) closing the lid will not go to suspend, forcing me to either plug back AC power or shut down, I can’t just take a break… :slight_smile: There are several reports of this suspend problem, no solution have I found so far while doing my homework.
  • Once updated to kernel 5.4.19, closing the lid causes a system freeze, every time, only a hard boot will get life again. I had reported this in F30 already, bugzilla 1791021 (sorry, new user, can’t put more than 2 links)
    Doing a web search for Fedora suspend freeze shows this situation is rather widespread. Something got messed up somewhere in 5.4 meseems
  • some people blame Nvidia. Not my case, vanilla Intel graphics here.

Actions taken: I had upgraded to F31 to see if this problem had been fixed. Seemed to, until I updated kernel, then freeze again. So a moment ago I just did *sudo dnf remove kernel-core-5.4.19-200.fc31.x86_64 * so that at least I always boot with the old kernel, tired of selecting manually at boot.

But even under 5.3.7, suspend seems to work only early in my session.
I am unsure if running under battery by itself causes it to fail. Under battery it seems to work some, but eventually I seem to do something that causes suspend to no longer work.

  • For a fact, mounting an SD card makes it fail.
  • It seems that sending something to the printer also has that effect.
  • I am unsure if some websites have that effect.

Also, once suspend fails, I can’t do a clean Power-Off. for example, it will go all the way to
Reached target: Power-Off.
systemd-shutdown[1]: Waiting for process: systemd-sleep

or else
printk: shutdown: 8 output lines suppressed due to ratelimiting

then simply sit there until I have to do a hard power off. My dear friend right here uses Windows, and just smirks at me, so embarrassing…

Is there some way to diagnose this systemd-sleep ? That way I could test things and figure out exactly what breaks that. Or what else should I look for? And, more importantly, is there a fix y’all know of? Suspend used to work perfectly (F29?) until some update last year.

other attempts at diagnostic:

for the fun of it, my inxi:
inxi -F -G -M
Host: localhost.localdomain Kernel: 5.3.7-301.fc31.x86_64 x86_64 bits: 64
Desktop: Xfce 4.14.2 Distro: Fedora release 31 (Thirty One)
Type: Laptop System: Hewlett-Packard product: HP EliteBook 2740p v: N/A
Mobo: Hewlett-Packard model: 7007 v: KBC Version 39.36
serial: BIOS: Hewlett-Packard v: 68COU Ver. F.04
date: 03/08/2011
ID-1: BAT0 charge: 23.5 Wh condition: 24.4/24.4 Wh (100%)
Topology: Dual Core model: Intel Core i5 M 560 bits: 64 type: MT MCP
L2 cache: 3072 KiB
Speed: 1410 MHz min/max: 1199/2667 MHz Core speeds (MHz): 1: 1414 2: 1288
3: 1453 4: 1447
Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel
Display: x11 server: Fedora Project 1.20.6 driver: modesetting
unloaded: fbdev,vesa resolution: 1280x800~60Hz
OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 19.2.8
Device-1: Intel 5 Series/3400 Series High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.3.7-301.fc31.x86_64
Device-1: Intel 82577LM Gigabit Network driver: e1000e
IF: enp0s25 state: down mac: 1c:c1:de:c2:91:c7
Device-2: Intel Centrino Advanced-N 6200 driver: iwlwifi
IF: wlo1 state: up mac: 18:3d:a2:99:c5:dc
Local Storage: total: 119.24 GiB used: 62.88 GiB (52.7%)
ID-1: /dev/sda vendor: LITE-ON model: LMH-128V2M-11 MSATA 128GB
size: 119.24 GiB
ID-1: / size: 29.40 GiB used: 10.97 GiB (37.3%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 975.9 MiB used: 168.8 MiB (17.3%) fs: ext4
dev: /dev/sda1
ID-3: /home size: 83.70 GiB used: 51.75 GiB (61.8%) fs: ext4
dev: /dev/dm-2
ID-4: swap-1 size: 2.70 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
System Temperatures: cpu: 49.0 C mobo: 0.0 C
Fan Speeds (RPM): N/A
Processes: 212 Uptime: 37m Memory: 7.57 GiB used: 1.65 GiB (21.8%)
Shell: bash inxi: 3.0.37


have you also tried the latest kernel (5.5.7 as of 2020-03-05)? Maybe the issue has been solved in the meantime.

The see the logs use journalctl. It will produce a long output, so maybe just show the last lines… the hibernating state should be logged last.

journalctl --boot=-1 | tail -n20

You can else if you discover something with

journalctl -xe

  There was a topic ... if WiFi is switched OFF, then the troubles go away (at least some of them)?

1 Like

It looks like you have 8 GB of RAM installed on your system. It also looks like you have a 2 GB swap partition.


Try making a swap partition 8 GB (at a minimum) or 16 GB and see if this problem still occurs?


thank you, Florian. I tried the journalctl, don’t really know what to look for, will keep at it a bit, perhaps. I wish I could figure out a way to diff files… (might end up installing Notepad++ in Wine)
following your suggestion, I dnf upgrade to 5.5.7 with hopes of a solution, wouldn’t that be nice? :-). No good, system freezes after resume. Filed 1810582 – resume after suspend frozen
Will remove 5.5.7 to have boot default to 5.3.7

something has been borked at least since F30. F27 seemed to work peaches… And, as you see in other requests, I’m not the only one with this kind of mess…

1 Like

Actually, troubles are nowhere if the whole system is off :slight_smile:
Srsly, this whole thing is weird, I have been testing this and that, and sometimes I manage to get the system to suspend even on battery. Like this: Firefox and Terminal, switching between one and the other, it’s like a flag got set somewhere, one time it suspends, one time it doesn’t, does not matter which of Terminal or Firefox was on top.
Works fora while, then eventually (don’t knwo what triggered it) suspend will not work any more, i.e., system stay ON even with lid closed.
Thank you for trying, yes, I had noticed a while back that wifi seemed to affect things, but obviously having wifi off is not very practical…

@ prthorsenjr why 2 GB swap? because that is what the system did when installing. Not my fault, honest!

Small-ish SSD, only 128 GB, had to twist arms to make the system partition be smaller than the 70 GB it wanted at first . The weird thing here is why things behave one way or another depending on battery or AC being the source of power… Same swap. (and then other weird behavior, as per my other note). AFAIK Swap has no relation with this, but who knows.

Just be sure on the swap issue, when you say ‘suspend’ you mean stand-by or sleep, not suspend-to-disk. Correct?

If you want suspend-to-disk (hibernating) you need at least as much swap space as your RAM size.


OH! sorry, good poitn, yes, “sleep”.

Not hibernate, haven’t used that in a while, but love it when I run out of power and it saves everything. Interesting, have been using his size swap for a while (4 years?), go figure if that plays some role in this mess, as Firefox is SO resource hungry.
Nowadays my sessions are rather brief, as by the time my system will not go to “sleep”, the fan is too noisy, so 3, 4-day sessions no more.

My next try will be to replicate what @ mj5030 did in May last year, Namely, downgrade systemd to 239, and block it from re-updating, that sounds promising (if not a real fix either, but, if it works…)

Again, you want to put your OS to sleep, swap doesn’t matter (while sleeping RAM is powered and doesn’t need to written to disk). So thats not the issue here.
Off topic: I have completely stopped creating a swap partition. If need swap space I just create a swap file on my root file system - this approach is much more flexible.


  Hi.  Probably it's a bad idea to increase the swap space this way.  For my experience, within a Gnome (Desktop use) session, my swap usage grows constantly, and then the system coming to crawl.  No swap now, as me isn't a server.
  But yes, i'm totally missed the hybernation point, i'm sorry.
  PS:  4 Gib of RAM.  Aren’t the actual rule is:  "The more RAM is the less swap".

1 Like

I believe you are right, with XFCE and 8 GB RAM, I seldom ever need swap. Actually, sort of unconsciously, if I notice that I am using swap, I suspect something is wrong somewhere, I don’t like the extra delay, even on an SSD.

As to testing without WiFi, I see your logic. In this current set of problems, I am noticing that wifi is “acting funny” from time to time, especially if I disable it with the manual switch, it won’t come back. It sort of sad to have been on Fedora for quite a few years already (10?) and seen things improving, like how I could connect to external monitors or projectors, printing, all those improved, and now things breaking down… I understand that there is an enormous amount of complexity, and somehow some good intention for some new feature is actually backfiring somewhere. I wish this were at least easier to diagnose, find what is breaking… Thank you for your care and willingness to help.

  Isn't there a rumors that "all cool perses switching to Silverblue?"

This is true. I worked with F29 for a while and it was great. Had I known I would have this problem until F33 I would never have updated.