Stuttering and gnome crashes problem

Hello everyone! Recently, I installed Fedora Silverblue 38 on my PC and ever since it had weird problems: occasionally the top half of the screen could become black for a brief moment (around 1 frame), in various applications including Firefox (both RPM and Flatpak versions), Ungoogled Chromium and MPV media player sometimes a small portion of sound may repeat, and sometimes Steam flatpak and MPV media player may crash my GNOME Desktop. Issues happen both on X11 and Wayland sessions. I also installed OpenBox through rpm-ostree and in OpenBox crashes and black flashes don’t occur, but the issue with repeating audio persists. I tried to test other distros via their live mode and those problems (flashing and repeats) also happen on Fedora 38 Workstation, Fedora 38 KDE Spin and also Debian 12 with GNOME, they don’t happen on latest Pop!_OS and Linux Mint, they also don’t happen on latest Windows 10. I have other machine running Fedora 38 Silverblue in my house (Xiaomi Mi Notebook Pro) and on it those issues don’t happen.
Layered packages are akmod-nvidia btop distrobox kmod-nvidia libva-utils nvidia-vaapi-driver openbox vdpauinfo virt-manager WoeUSB xorg-x11-drv-nvidia xorg-x11-drv-nvidia-cuda, and I also changed some kernel arguments via sudo rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init . None of those changes to the system had effect on those issues. My PC uses Intel Core I5 2400 and Nvidia GTX 1050, 8 GB of DDR3 RAM and the system is installed on 512 GB SATA SSD, I’m not sure what else I may share to help with troubleshooting

I also found that I can’t get working hardware acceleration on firefox flatpak on PC, while it works out of the box on laptop. Both of them use CPUs by Intel, GPUs by Nvidia and proprietary Nvidia drivers

I also found that sometimes the “fedora logo” GNOME extension may “leak” through overlapping windows when CPU usage is high. The frequency of audio repeats and lags depend on CPU usage, but happens even when it is low, every stutter is followed by quick increase of CPU usage graph in GNOME system monitor around 25% high, lasting less than a second (e.g., if my current CPU usage is 25%, after the stutter it will become 50% and then become 25% again). I also realized that “top half of the screen flashing black” issue happens only when I use 144 Hz refresh rate, it doesn’t happen with 60 Hz.
It still doesn’t explain why all this only happens in some Linux distributions including Fedora Workstation, Fedora Silverblue and Fedora KDE spin, and happens only on one of my PCs

This indicates it is a graphics issue (either driver or hardware) and should be addressed that way.

I don’t use silverblue, but I do deal with nvidia a bit.
Please post the output of inxi -Fzxx so we can see the hardware and drivers config.

Hello! Thank you for your reply!
Here is the output:

System:
  Kernel: 6.4.7-200.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.3 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
Machine:
  Type: Desktop Mobo: ASRock model: Z68 Extreme3 Gen3
    serial: <superuser required> BIOS: American Megatrends v: P1.30
    date: 11/22/2011
CPU:
  Info: quad core model: Intel Core i5-2400 bits: 64 type: MCP
    arch: Sandy Bridge rev: 7 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 1598 high: 1600 min/max: 1600/3400 cores: 1: 1600
    2: 1596 3: 1596 4: 1600 bogomips: 24741
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: ASRock driver: i915 v: kernel arch: Gen-6 ports: active: none
    empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0102
  Device-2: NVIDIA TU117 [GeForce GTX 1650] vendor: Micro-Star MSI
    driver: nvidia v: 535.86.05 arch: Turing pcie: speed: 2.5 GT/s lanes: 16
    ports: active: none off: HDMI-A-4 empty: DVI-D-1 bus-ID: 01:00.0
    chip-ID: 10de:1f82
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa alternate: nv dri: crocus
    gpu: nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: HDMI-A-4 model: Philips PHL 242E1GZ res: 1920x1080 dpi: 93
    diag: 604mm (23.8")
  API: OpenGL v: 4.6.0 NVIDIA 535.86.05 renderer: NVIDIA GeForce GTX
    1650/PCIe/SSE2 direct-render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: ASRock driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20
  Device-2: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    pcie: speed: 5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
  API: ALSA v: k6.4.7-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 05:00.0 chip-ID: 10ec:8168
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8812AE 802.11ac PCIe Wireless Network Adapter
    driver: rtl8821ae v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: c000
    bus-ID: 07:00.0 chip-ID: 10ec:8812
  IF: wlp7s0 state: down mac: <filter>
Drives:
  Local Storage: total: 3.27 TiB used: 890.06 GiB (26.5%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Kingston model: SUV300S37A120G size: 111.79 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-3: /dev/sdc vendor: Toshiba model: DT01ACA200 size: 1.82 TiB
    speed: 6.0 Gb/s serial: <filter>
  ID-4: /dev/sdd vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
Partition:
  ID-1: /boot size: 973.4 MiB used: 105.2 MiB (10.8%) fs: ext4 dev: /dev/sda2
  ID-2: /var size: 446.13 GiB used: 46.81 GiB (10.5%) fs: btrfs
    dev: /dev/sda3
Swap:
  ID-1: swap-1 type: zram size: 7.66 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 293 Uptime: 1m Memory: available: 7.66 GiB used: 2.31 GiB (30.2%)
  Init: systemd v: 253 target: graphical (5) default: graphical Compilers:
  gcc: 13.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak pkgs: 86
  Shell: Bash v: 5.2.15 running-in: gnome-terminal inxi: 3.3.27

While it is quite true that an Nvidia GTX 1650 is capable of supporting a screen at 1920x1080 at 144 Hz refresh (my laptop does that quite readily), I have to ask if the external monitor is capable of that refresh rate and if the HDMI interface will support that. When I attach via HDMI to an external monitor I cannot ever get better than 60 Hz refresh. I have no monitors other than the built-in laptop screen that support higher refresh rates.

Even if both the monitor and the hdmi port support the higher refresh, the cable used is also a factor and may interfere.

One must analyze the situation and verify that every component supports the desired config. The weakest component is the limiting factor.

If you know the monitor supports the 144 Hz refresh then the first change I would recommend would be to get a new best available quality HDMI cable and try that. If the monitor does not support 144 Hz refresh then it would be best to quit trying since that might eventually cause the monitor to fail (quite possibly very soon).

All of the components are capable of 144 Hz and it works flawlessly in Windows and Pop!_OS

I think that this issue may be dependent on Linux kernel version. Is there a way to switch kernel versions in Silverblue?

Currently I don’t see any options to record those audio issues, but they sound like if you’ll delete a small part of an audio file (less than a second long) and patch its place with audio that is immediately before it. For example, when I’m listening to voice and it says “apples”, I may hear “appl…app” instead. Such stutters happen in every single app that uses audio, sometimes they happen when CPU load rapidly changes, but even on low CPU load it still happens

I installed Fedora Workstation again and this bug with sound somehow resolved on its own. Black flashes of the top half of the screen were caused by version of Nvidia driver that was too new for my GPU, despite claims on the official Nvidia website that this version of driver is compatible.

When making a claim such as this, while it may be true, currently has no detail to support that conclusion. Please provide information about the gpu that you claim is not supported, info about the driver and kernel version used that did not work, AND the changes to drivers and/or kernels that aided in the solution.

Detailed info may assist others in finding the problem and the solution if they happen to experience similar problems

My GPU is GTX 1650 and the version of driver where flashes happen is 535.113.01
Output of /sbin/lspci | grep -e VGA :
01:00.0 VGA compatible controller: NVIDIA Corporation TU117 [GeForce GTX 1650] (rev a1)
I did not tried it on Fedora yet (I don’t know how to do it properly), but installing 525 driver fixed this issue on Pop OS

So after a system upgrade, the 535.129.03 driver got installed and it seems to have fixed the half screen flashing issue

Once again you failed to provide the requested information. The system upgrade is so generic that we have no clue what may have been upgraded other than the stated nvidia driver version. Many things interact and may have been part of the solution.