Stuck in emergency mode after upgrade

I just upgraded from Fedora 31 to Fedora 32 as described here and now I always get stuck in this emergency mode here (right after entering my luks password):

I’m using the KDE spin of Fedora. It’s a laptop (x64) and I’ve never had severe upgrading issues like that on it before.
There whole system is on one SSD. After entering my root password in the emergency mode I can browse all my files just fine. There are no errors in dmesg and I couldn’t find anything that looked critical to me in journalctl -xb.
Selecting an older (Fedora 31-)kernel got me stuck in emergency mode as well. I’ve also tried removing all custom kernel parameters that I have successfully been using in Fedora 31 (Just some iommu/vfio and GPU driver stuff)

I’d really like to avoid restoring to my backup as this takes about 4 hours and then another 2 hours to upgrade again.

Is there anything I can do?

Try entering emergency mode and viewing logs as suggested. Then, could you post those logs here? Perhaps something pops up…

Messages that are on the screen unfortunately don’t provide me with much details.

1 Like

Thanks for the response. Unfortunately it’s incredibly difficult for me to take proper photos of my screen, but here is the output of journalctl -xb

And here is another photo after i have scrolled all the way down.

I can grep specific sections if you give me a keyword or pattern, but I can’t take hundreds of pictures of my screen to give you the full output of journalctl -xb. :slightly_frowning_face:

I have now tried running:

fsck -f /dev/mapper/fedora_localhost–live-root
(offered two optimizations that I accepted)
fsck -f /dev/mapper/fedora_localhost–live-swap
(didn’t offer anything)
fsck -f /dev/mapper/luks-{ID}
(didn’t offer anything)
fsck -f /dev/sdb3
(didn’t offer anything)

which was suggested here.

But I’m still getting stuck in emergency-mode…

Here is the output of my journalctl -xb (only the lines that contain the word error or warning or failed, plus the 4 succeeding lines respectively):

Any ideas? :frowning_face:

Edit: I can get rid of that firmware load error by removing my iommu/vfio kernel params btw, but it still doesn’t fix my problems…

There seems to be some home-fedora-Projects-server_mount.mount that’s failing. I guess that’s some network mount which is inaccessible at this moment. Trying to mount it during the boot-time, similar to fstab, might cause issues. Try disabling that mount and seeing if it will help with booting into normal desktop.

It might also be that you haven’t created that mount directly in systemd, but for example added it to /etc/fstab entry and then systemd-fstab-generator picked it up. In that case just comment it out of there.


Yeah I was wondering what that could be. The weird thing is that the system always booted fine, even without a network connection before I upgraded. I don’t think I ever manually created a mount like that. It’s possible that I added a nfs share from my NAS in the dolphin file explorer. I’ll try to get rid of it and report back.

Edit: Turns out it was some sort of ssh mount of one of my servers. Not sure how this got added to my fstab file.

Thank you so much!! Removing this mount actually fixed it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.