Stuck in boot screen after clean install of Fedora 34


I decided to reinstall fedora 34 since I wanted to have my disk encrypted and a reinstall seemed like the easiest way to go. I have a laptop with dual graphics (Intel HD + NVIDIA GPU). I chose the recommended settings in the installer and used the image Fedora-Workstation-Live-x86_64-34-1.2.iso

The installer ran fine, but the system gets stuck in the boot screen. After removing rhgb quiet from the grub entry I can see the error message (see screenshot below):
nouveau 0000:01:00.0: acr: unload binary failed

Rescue mode works! I booted there and tried a dnf update and installing the NVIDIA drivers from RPMFusion, but it didn’t help.

Any ideas on how to solve this problem? Many thanks!

Note: Fedora 34 was working before in the same system. (Updated from 33).

Happy note to future self:

  • Installing the drivers from rescue actually helped.
  • However, the new akmod wasn’t built yet.

How I solved it:

  • After installing the drivers, the grub entry has some additional options appended like rd.driver.blacklist=nouveau. Replace them with nomodeset. This apparently loads the system without drivers.
  • Ctrl-x to boot, wait until it gets stuck again.
  • Once it’s stuck, Ctrl+Alt+F3 to jump to the console.
  • reboot. This will trigger the rebuild of the new akmods.
    And voila, the system works again :slight_smile: *happy fedora noises*

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.