Stratis reboot issue

We do need more info’s.

Did you follow a tutorial? The Fedora Magazine article or just the install manual from the website:
Stratis Storage ?

Can you boot into rescue mode and give us info’s from the boot-log for example?

sudo sed $'s/\^\[/\E/g' /var/log/boot.log

If you have not had time yet please read also the #start-here section to get an idea what kind of info is useful to be able to help you.

I got into /etc/fstab on root terminal and erased the stratis mount point and rebooted, below is result. Yes, I followed instructions you mentioned.



[bob@localhost-live ~]$ sudo dnf update -y
[sudo] password for bob:
Fedora 37 - x86_64 - Updates 75 kB/s | 18 kB 00:00
Fedora 37 - x86_64 - Updates 358 kB/s | 446 kB 00:01
Fedora Modular 37 - x86_64 - Updates 98 kB/s | 23 kB 00:00
Dependencies resolved.
Nothing to do.
[bob@localhost-live ~]$ sudo sed $‘s/^[/\E/g’ /var/log/boot.log
[ OK ] Finished logrotate.service - Rotate log files.
[ OK ] Started thermald.service - Thermal Daemon Service.
[ OK ] Started systemd-logind.service - User Login Management.
[ OK ] Started systemd-machined.service - Virtual Machine and Container Registration Service.
[ OK ] Started rtkit-daemon.service - RealtimeKit Scheduling Policy Service.
[ OK ] Started avahi-daemon.service - Avahi mDNS/DNS-SD Stack.
[ OK ] Finished unbound-anchor.service - update of the root trust anchor for DNSSEC validation in unbound.
[ OK ] Started switcheroo-control.service - Switcheroo Control Proxy service.
[ OK ] Started abrtd.service - ABRT Automated Bug Reporting Tool.
[ OK ] Started polkit.service - Authorization Manager.
Starting ModemManager.service - Modem Manager…
[ OK ] Started abrt-journal-core.service - Creates ABRT problems from coredumpctl messages.
[ OK ] Started abrt-oops.service - ABRT kernel log watcher.
[ OK ] Started abrt-xorg.service - ABRT Xorg log watcher.
[ OK ] Started alsa-state.service - Manage Sound Card State (restore and store).
[ OK ] Reached target - Sound Card.
Starting firewalld.service - firewalld - dynamic firewall daemon…
[ OK ] Started power-profiles-daemon.service - Power Profiles daemon.
[ OK ] Started accounts-daemon.service - Accounts Service.
[ OK ] Started upower.service - Daemon for power management.
[ OK ] Started udisks2.service - Disk Manager.
[ OK ] Started firewalld.service - firewalld - dynamic firewall daemon.
[ OK ] Reached target - Preparation for Network.
Starting NetworkManager.service - Network Manager…
[ OK ] Started NetworkManager.service - Network Manager.
[ OK ] Reached target - Network.
Starting NetworkManager-wait-online.service - Network Manager Wait Online…
Starting cups.service - CUPS Scheduler…
Starting gssproxy.service - GSSAPI Proxy Daemon…
Starting systemd-hostnamed.service - Hostname Service…
[ OK ] Started gssproxy.service - GSSAPI Proxy Daemon.
[ OK ] Reached target - NFS client services.
[ OK ] Started cups.service - CUPS Scheduler.
[ OK ] Started systemd-hostnamed.service - Hostname Service.
[ OK ] Listening on systemd-rfkill.socket - Load/Save RF Kill Switch Status /dev/rfkill Watch.
[ OK ] Started ModemManager.service - Modem Manager.
Starting NetworkManager-dispatcher.service - Network Manager Script Dispatcher Service…
[ OK ] Started NetworkManager-dispatcher.service - Network Manager Script Dispatcher Service.
[ OK ] Started stratisd.service - Stratis daemon.
[ OK ] Finished NetworkManager-wait-online.service - Network Manager Wait Online.
[ OK ] Reached target - Network is Online.
[ OK ] Reached target - Preparation for Remote File Systems.
[ OK ] Reached target - Remote File Systems.
Starting rpc-statd-notify.service - Notify NFS peers of a restart…
Starting systemd-user-sessions.service - Permit User Sessions…
Starting virtqemud.service - Virtualization qemu daemon…
[ OK ] Started rpc-statd-notify.service - Notify NFS peers of a restart.
[ OK ] Finished systemd-user-sessions.service - Permit User Sessions.
Starting gdm.service - GNOME Display Manager…
Starting plymouth-quit-wait.service - Hold until boot process finishes up…
[ OK ] Started virtqemud.service - Virtualization qemu daemon.
[ OK ] Started gdm.service - GNOME Display Manager.
[bob@localhost-live ~]$

I do not know how to get into rescue mode with the existing Stratis mount point intact

While rebooting press Esc or the Shift key and select “enter rescue mode”.

Mostly last boot entry … select with Up or Down

Robert L Sisk
(210) 716-6400

I hope the photos I sent will help. I saw 3 dependencies failures. Is that the problem?

Robert L Sisk
(210) 716-6400

When I check the checksum to verify the Fedora 37 download I get the attached message that 17 lines are improperly formatted - does this have anything to do with my Stratis problem?

Screenshot from 2022-11-18 18-49-50.png

Hi Robert! Edit: Just saw your /etc/fstab. That is definitely the problem. Usually when there’s a timeout, it’s because the device that you specified never became available. This often occurs when the /etc/fstab dependencies for the Stratis filesystem are not added properly as outlined here. Please follow that guide and it should resolve your issue.

1 Like

Hi John, thanks so much for the additional information. I do not have the technical expertise to completely interpret and understand your response, but I think I have followed your steps correctly. I have attached my /etc/fstab file for your review to make sure I have set Stratis up correctly. It is booting OK now. I have Stratis set up on my /dev/sdc disk, and I intend to set up /dev/sda and /dev/sdb as a RAID1 BTRFS system like I have been running on Fedora 36. I plan to run both systems until I am confident with Stratis. I plan on using my RAID1 as main storage and rsync to Stratis as a backup to duplicate the data. Will this work OK? Any help appreciated.



While still logged in you can test if that entry in /etc/fstab works properly by using mount -a on the command line. If it works properly the file system will be mounted and you can be assured that it would work when you next reboot. If it fails to mount then you know there is an error and it would need to be modified until it does mount before you reboot.

I am not familiar with stratis, nor have I looked into the documentation so my comment is only related to how to test & verify the fstab entry is correct before you rely on it during a boot.

Remember also that you made the entry into /etc/fstab and should run systemctl daemon-reload as noted before attempting the ‘mount -a’ command above.

Thanks Jeff, I discovered that along the way, but with my Stratis incorrect line item in /etc/fstab the first go-around it mounted and unmounted when I used “mount -a” okay, but when I rebooted it hung and went into rescue mode. After I entered John’s instructions for /etc/fstab it works properly as far as mounting in /etc/fstab and also then boots okay.

Robert L Sisk
(210) 716-6400

@bobbybiceps will you mark the request of

as solution then?

Yes, it seems to be working now, but I would like confirmation on my /etc/fstab that I posted to make sure I have done that correctly.

Hi Bob!
The format looks correct for the /etc/fstab entry. I can’t confirm that things like the UUID are correct without more information, but if it’s correctly set up, that’s a good indication you’ve done it correctly. :slight_smile: One things to keep in mind is that you’ve added the nofail option so just make sure that the Stratis filesystem is indeed mounted as nofail will not fail a boot even if the mount was unsuccessful.

Yes, everything is mounting okay, should i delete the no fail?

I deleted your phone and email from the post above. Having them public invites a lot of spam and malware attacks.

Not necessary to delete that option, but do be aware that even if mounting fails the boot will continue anyway.


When you send the response as email from your ipad it sends the phone number and email address. I removed it again.

You want nofail if:

  • you don’t want the boot to fail
  • the pool does not require a passphrase to unlock

nofail prevents waiting on the prompt to the user for the passphrase. Pools that have either Clevis enabled or are unencrypted can safely use the nofail if desired.

If the pool is encrypted and only has a passphrase (no Clevis bindings) or you want the boot to fail if mounting fails, never use nofail.

Does that all make sense?

1 Like