Strange issue with app menu/permissions after ugrade to Fedora 37

hello. When i launch flameshot from app menu it launches normally but it doesn’t take screenshots or even ask for a permission to sceen capture, it just hangs for a few seconds and nothing happens. BUT if i launch it from app center or console it works perfectly fine. And i have similar issue with steam, it can’t delete games when launched from app menu, but launched from console it again works perfectly fine. So i don’t even know how to start troubleshooting since using console fixes the problem. I tried reinstalling. Pls send help //fedora37, gnome43, wayland

Have you by chance tried the same steps with xorg instead of wayland? It might be a wayland issue, but cannot tell without testing.

1 Like

yes, i just checked, it doesn’t reproduce on x11. And back on wayland it still does

Sounds to me like it is a candidate for a bug to be filed against wayland.

i got error message for flameshot on wayland from sys log:

systemd[2358]: Started app-gnome-org.flameshot.Flameshot-322731.scope - Application launched by gnome-shell
xdg-desktop-por[3151]: Failed to show access dialog: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Only the focused app is allowed to show a system access dialog

When i launch it not from app menu there is no logs at all.

I can’t reproduce problem with steam anymore, and it probably was unrelated to that one

here is the answer to the flameshot issue: Take Screenshot on Gnome without Prompt · Issue #2868 · flameshot-org/flameshot · GitHub

  1. Run flameshot
  2. Open flameshot’s settings window(I also maximized the window to lower the chances of loosing focus of that window - probably not needed)
  3. Take a screenshot using flameshot - I clicked the tray icon that came from a gnome extension
  4. Permissions question should appear - grant it
  5. It should now work fine without asking for permissions next time you take a screenshot

thank you