Steam only shows user interface when launching with integrated graphics

I’ve had this issue for a month or so now. When I launch Steam, it loads but will not show the interface. I know it’s running because I have the tray icon and can even launch games from the tray. They seem to work fine. I have to right click and select integrated graphics when I start Steam to show the interface. I’m currently using the Flatpak.

Last night, I figured I would move my data directory and reinstall. It worked last night. Today, I restarted and I’m right back to not having the interface on my AMD. I’ve even tried switching to X11 and still get the same issue.

This wouldn’t be a huge deal as I could just configure Steam to always launch with the integrated graphics but I’m pretty sure it launches games with what ever Steam was launched with. I would have to go in and tell it to launch each game with the AMD graphics. Again, it’s a workaround but I would rather not.

I did a web search but couldn’t find anything that was quite the same issue and I’m stumped.

Edit: Just for grins, I uninstalled the Flatpak and installed the RPM. Same issue. It launches fine the first time and then after that, I have to specifically tell it to launch with the integrated graphics to get the interface to show.