StartX error while trying to turn server Fedora into desktop

Hello Im trying to install qtile on server fedora. I have installed the needed dependencies for xorg, i have created a python venv for qtile in which i have git cloned their repo from which i copied the default config into .config and also copied the binaries. I put “qtile start”in .xinitrc and used startx to start it but it gives me the error displayed on the picture

It says “server terminated successfully”. Doesn’t that mean that qtile exited? What happens if you run, e.g., /usr/bin/xterm instead of qtile?

Nothing happens. It spits out the same error


Now i see that there an error from xauth that serverauth 1644 doesn’t exist

Added x11-wayland-transition

Added qtile, x11 and removed x11-wayland-transition

Maybe try deleting your old ~/.Xauthority file? Also, I think the last line in your ~/.xinitrc that launches your window manager is supposed to start with exec. For example, exec qtile start. Lines prior to that last line should end with &. For example, xterm &.

Edit: Also, make sure you don’t have any files in your home directory that are owned by root. That can happen if you tried to run startx as root which you shouldn’t do.

1 Like