Starting Disk Manager - Can no longer boot into fedora

Yesterday my computer was fine, today I can’t even boot into fedora. I tried all the different kernels offered in the boot menu and I tried rescue mode. I am always presented with this screen.

These are the options are the option in the boot screen

I am using Nvidia Drivers and LUKS encryption. I can get into the terminal by pressing ctrl+alt+f2 but I get no GUI even with startx.

I think I solved it. The problem was that I had two cuda repos.
I solved it by disabling one of them.

#1 Determine which cuda package to keep

First I needed to determine which cuda package to keep. I decided to keep the more recent one. The command I used to determine that is.

[julius@joy yum.repos.d]$ ls -lt | grep cuda
-rw-r--r--. 1 root root  210 Nov 11 17:15 cuda.repo
-rw-r--r--. 1 root root  210 Nov 11 17:08 cuda-fedora29.repo

#2 Disable the one I don’t want to keep

Go to the dir where the repos are stored cd /etc/yum.repos.d
edit the cuda.repo file sudo nano cuda.repo
change enabled=1 to enabled=0


#3 Update

Then I did sudo dnf update and restarted and it works now.

[julius@joy yum.repos.d]$ sudo dnf update
[sudo] password for julius: 
Repository cuda is listed more than once in the configuration
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.