SSL_ERROR_SYSCALL errors while trying to connect to any HTTPS site. Solved only by disabling ipv6. How to resolve this issue in a proper way without disabling ipv6?

I am on F34 GNOME with Wayland. Laptop is HP ZBook series.


As I remember, I’ve suspended my laptop and resumed it after some time. Then I have observed that I am not able to connect to any HTTPS site. I’ve tried curl -v just to check and got SSL_ERROR_SYSCALL error.

Temporary Solution (I found online)

After some digging in, I found a post on stack overflow suggesting to see if the default DNS resolutions are pointing to ipv6 addresses and if so, to disable ipv6. That’s the exact thing happening for me. My curl command showed ipv6 address. So, as suggested, I’ve disabled ipv6 with sysctl -w net.ipv6.conf.all.disable_ipv6=1 and sysctl -w net.ipv6.conf.default.disable_ipv6=1 commands and my problem was resolved. Now, I know I can add these commands in /etc/sysctl.d/99-sysctl.conf to disable ipv6 automatically during startup.

But I feel this is only some temporary fix. This is not the proper solution. I don’t want to disable ipv6 completely. I am preparing for CCNA and I do need ipv6 for my studies and understanding. I want to resolve this issue in a proper way. Seems this has to do something with systemd-resolved. Can anyone give me some direction where to check and how to proceed further ?

1 Like