Hi,
After dnf-auto-update on 26th August 2026 I started to experience problems in SSHing into my server. It ignores the publickey and falls back to password login. Once I login, I get a message:
Could not chdir to home directory /home/username: Permission denied
Then and I end up in the root directory. Once there, I can, however, cd into my home directory which is on a RAID.
I added a foobar user with home being away from the RAID mount somewhere in /var/lib.
Then I added my pub key to that user’s authorized_keys -file and managed to login successfully without password prompt. If I move that foobar user’s home under /home, the RAID partition, it falls back to password login. If I move the home directory back to /var/lib, key based login works again.
I’ve set up sshd to debug3 level logging and I get two lines relating to the key exchange:
debug3: mm_answer_keyallowed: publickey authentication test:
ED25519 key is not allowed
Failed publickey for username from 192.168.1.62 port 65093
ssh2: ED25519 SHA256:[CORRECT KEY FINGERPRINT HERE]
Does anyone have an idea what could cause the issue here?
I’ve checked the RAID status with mdadm -D /dev/md127 & cat /proc/mdstat and both state the array is OK.
My .ssh directory’s mode bits are 0700, and authorized_keys within it 0600.
I’m thinking something in the latest autoupdate broke something, since I’ve not done any changes to the server manually between 24th (the previous successful key based login) and yesterday, the 26th.
