Sound sometimes doesn't work with AudioEngine HD3 USB speakers

Hi Team
No sound after an update. Using F38.
Sound is AudioEngine HD3 USB speakers.
The sound icon is available and the speakers are selectable as an output device… but nothing.
There seems to be some issues with the pipewire services. I have another workstation running the same kernel and version without issue. Any help or pointers on how to troubleshoot very much appreciated. Thank you :slight_smile:

❯ lsof /dev/snd/*
pipewire  1828 wolf   45u   CHR  116,1      0t0  557 /dev/snd/seq
pipewire  1828 wolf   46u   CHR  116,1      0t0  557 /dev/snd/seq
wireplumb 1829 wolf   31u   CHR 116,16      0t0  978 /dev/snd/controlC0
wireplumb 1829 wolf   33u   CHR 116,14      0t0  895 /dev/snd/controlC1
wireplumb 1829 wolf   34u   CHR  116,8      0t0  870 /dev/snd/controlC2

❯ systemctl --user status pipewire pipewire-pulse wireplumber pulseaudio
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
     Active: active (running) since Mon 2023-04-24 15:03:16 NZST; 40min ago
TriggeredBy: ● pipewire.socket
   Main PID: 1828 (pipewire)
      Tasks: 2 (limit: 9353)
     Memory: 11.3M
        CPU: 228ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─1828 /usr/bin/pipewire

Apr 24 15:03:16 fedora systemd[1799]: Started pipewire.service - PipeWire Multimedia Service.
Apr 24 15:03:16 fedora pipewire[1828]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Apr 24 15:03:16 fedora pipewire[1828]: mod.rt: found session bus but no portal

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; preset: disabled)
    Drop-In: /usr/lib/systemd/user/service.d
     Active: active (running) since Mon 2023-04-24 15:03:17 NZST; 40min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 2200 (pipewire-pulse)
      Tasks: 2 (limit: 9353)
     Memory: 13.9M
        CPU: 197ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─2200 /usr/bin/pipewire-pulse

Apr 24 15:03:17 fedora systemd[1799]: Started pipewire-pulse.service - PipeWire PulseAudio.
Apr 24 15:03:17 fedora pipewire-pulse[2200]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Apr 24 15:03:17 fedora pipewire-pulse[2200]: mod.rt: found session bus but no portal

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; preset: enabled)
    Drop-In: /usr/lib/systemd/user/service.d
     Active: active (running) since Mon 2023-04-24 15:03:16 NZST; 40min ago
   Main PID: 1829 (wireplumber)
      Tasks: 5 (limit: 9353)
     Memory: 11.7M
        CPU: 459ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─1829 /usr/bin/wireplumber

Apr 24 15:03:16 fedora systemd[1799]: Started wireplumber.service - Multimedia Service Session Manager.
Apr 24 15:03:16 fedora wireplumber[1829]: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal running?
Apr 24 15:03:16 fedora wireplumber[1829]: found session bus but no portal
Apr 24 15:03:16 fedora wireplumber[1829]: SPA handle 'api.libcamera.enum.manager' could not be loaded; is it installed?
Apr 24 15:03:16 fedora wireplumber[1829]: PipeWire's libcamera SPA missing or broken. libcamera not supported.
Apr 24 15:03:17 fedora wireplumber[1829]: GetManagedObjects() failed: oUnit pulseaudio.service could not be found.

❯ systemctl --user status xdg-desktop-portal.service 
● xdg-desktop-portal.service - Portal service
     Loaded: loaded (/usr/lib/systemd/user/xdg-desktop-portal.service; static)
    Drop-In: /usr/lib/systemd/user/service.d
     Active: active (running) since Mon 2023-04-24 15:03:20 NZST; 41min ago
   Main PID: 2685 (xdg-desktop-por)
      Tasks: 7 (limit: 9353)
     Memory: 3.6M
        CPU: 81ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/xdg-desktop-portal.service
             └─2685 /usr/libexec/xdg-desktop-portal

Apr 24 15:03:18 fedora systemd[1799]: Starting xdg-desktop-portal.service - Portal service...
Apr 24 15:03:20 fedora systemd[1799]: Started xdg-desktop-portal.service - Portal service.
Apr 24 15:12:29 fedora xdg-desktop-por[2685]: Realtime error: Could not map pid: Could not determine pid namespace: Could not find instance-i

Update: I plugged in some wireless headphones (USB dongle) and they work… What would it be with the speakers over USB?

Update: Adding USB Driver information:

41: USB 00.0: 0401 Multimedia audio controller
  [Created at usb.122]
  Unique ID: +l7F.udgDYkIHzaF
  Parent ID: Opph.LymQWhJErPB
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-14/1-14.1/1-14.1:1.0
  SysFS BusID: 1-14.1:1.0
  Hardware Class: sound
  Model: "Cambridge Silicon Radio Audioengine HD3"
  Hotplug: USB
  Vendor: usb 0x0a12 "Cambridge Silicon Radio, Ltd"
  Device: usb 0x4097 "Audioengine HD3"
  Revision: "14.86"
  Serial ID: "ABCDEF0123456789"
  Driver: "snd-usb-audio"
  Driver Modules: "snd_usb_audio"
  Speed: 12 Mbps
  Module Alias: "usb:v0A12p4097d1486dc00dsc00dp00ic01isc01ip00in00"
  Driver Info #0:
    Driver Status: snd_usb_audio is active
    Driver Activation Cmd: "modprobe snd_usb_audio"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #35 (Hub)

I have similiar problem with sound. It works with bluetooth headphones, but not the computers speakers/microphone. Well it works, but I get this:
Zaslonska slika 2023-04-24 09-47-32

ps. Now it changed and I can use it, but the shortcuts for muting the sound and the mic don’t work as expected. The light is always on (mic) or always off (sound) and if I press them fast, nothing happens. It need couple of seconds to work…

I updated this morning:
Thinkpad X1 Carbon Gen9
Fedora 38
Linux 6.2.11-300.fc38.x86_64
Pipewire 0.3.70

Update: Working!
Hi Team, I dunno what to say. Its working.
Only changes?

  • Power cycled speakers.
  • Unplugged cables from both ends of speakers (speaker and PC).
  • Changed outputs to another source.
  • Changed output back to the AudioEngine speakers.

I almost fell off my chair when the sound came through :slight_smile:
I was hoping for something a little more concrete to share with the community but glad they working again.

Update! Not working :frowning:
It didnt last beyond a session. Most strange.

Ok Fresh Install and same issue out of the box.
Its gotta be something in F38.

Anyone have any ideas? Roll back to 37 seems likely. Strangely, I had no issues at all with F38 beta.

I just updated the kernel version to Linux 6.2.12-300.fc38.x86_64, but the issue with sound is still here.
Can you choose between sources in input/output?
I cannot :confused:

edit: to see if the issue is the same or should I open new thread.

I can choose input and output. These are not greyed out.
If I unplug the speaker and then plug back in it disappears and then is visible.
The sound output level on the test meter shows output but nothing. Its super weird and annoying.
Kernel for your reference:

1 Like

In a terminal can you check alsamixer use F6 to select your soundcard and see what the volume levels are?

1 Like

Screenshot from 2023-04-26 06-34-04
Set to 55.

I found a few posts about this device

Audioengine HD3 linux no sound at DuckDuckGo

The common thread seems to be a mismatched sample rate, but most of the solutions are old (PulseAudio).

Run this command and reply with the given URL:

( --stdout; pactl list) | fpaste
1 Like

Apologies for late reply I was in late last night.
Updates overnight seems to have fixed the issue and sound ok after reboot.

1 Like

Have solved the issue through installation of pipewire-pulseaudio. This replaces pulseaudio wich, as I noticed, causes the problem with audio: when I were killing pulseaudio I could hear sounds of volume change actions.
Key --allowerasing was required

Article PipeWire - ArchWiki prompted the idea.

Your comment does not seem related to this topic, which was about PipeWire in the first place.

FYI, Fedora has used PipeWire by default since F34.

Try to find the topic on the page, it says “No sound after F38 Update”, not what you say.
I had no sound after the update.

It was all right with pipewire on my PC. But somehow pulseaudio appeared in my system.

FYI, pipewire and pulseaudio live on different layers.

I understand your confusion over the vague title. This topic is about intermittent sound with AudioEngine HD3 USB speakers using PipeWire (the default) on F38.

If you can’t remember why you installed pulseaudio previously, you can check the transaction history:

dnf history list pulseaudio
dnf history info <transaction id>
Its happened again after updates. If I go to sound settings and test it sometimes works and sometimes not. Pasted the output.

The other thing I see is the following:

usb 1-6.1: 1:1: cannot set freq 48000 to ep 0x3

Any ideas?

There’s some ongoing talk on kernel mailing list related to this, but I don’t know if it affects anything in your case. Your Audioengine still reports it’s working at 48000 Hz, and there’s no other indication of any problems.

How exactly does the problem manifest? e.g. it works initially on boot, then after X time playing audio, it suddenly stops? Does it ever restart by itself? Or audio cuts in and out repeatedly?

Do you use the other audio devices (front/back panels jacks or HDMI)?

I can add myself to this list.

Audio sometimes works sometimes it doesnt, i depends on some boot error, i dont know, is the most lulz bizarre stuff ever!

Im updating right now there is a pulse audio update.

It is intermittent. It can be fine and then I will try to play something and it just does not produce volume. I can see the channel is active (the bars move) but nothing. I can sometimes fix it by changing the sound output and then back and testing the speakers. This can sometimes work then stop midway through the test.
I tried disconnecting during a reboot but same behaviour. The monitors have speakers over HDMI but I dont use them. Just the AudioEngine. It is most weird!

Did the update help or hinder?