Sound output not detected for device

So recently I got a Yamaha Natural Sound Receiver R-S202 for my speakers. To use it, the two main inputs that exist are bluetooth and audio jack. To be able to connect to audio jack, you have to use a cable that converts L+R to one (not sure what it’s called).

The point is, on my phone and other OSes I’m able to play via this output. My problem is on Fedora linux (on my Razer Blade 15 (2018) laptop), just pavucontrol doesn’t show this output.

I’m trying to troubleshoot this by looking at pactl/pacmd, but I’m not sure why this isn’t working. It seems like most people with this issue have it for a separate reason or just give up. Someone on the Fedora Discord said I should ask for help here. Thanks.

Hello and welcome to the forum.

Tell me if I got this right:
You are using a 3.5mm jack to RCA cable to connect the output of your laptop to the input of your amplifier.
If that is the case, the laptop has no way of knowing what lies at the other end of the cable, so it should identify the connection as headphones - you should see something like “Headphones (plugged in)” in pavucontrol and “Headphones - Built-in Audio” in GNOME’s settings. If you can use a pair of regular headphones with your laptop, there is no reason it won’t work with the amplifier, it’s an analog output.

1 Like

Didn’t show up. It shows up when I list devices in pacmd/pactl.

Do actual headphones work when you plug them in? If they do, then the problem lies elsewhere.
If they don’t, try to use pavucontrol to unmute the output or get an idea what is happening when you plug in the headphones. Might also be worth a try with alsamixer.

1 Like

Thanks so much. I kept thinking that the Built-in whatever was my speakers. I set the output to that and everything’s working. You don’t know how much longer I would have gone with this problem due to my own incompetence.

1 Like

Good to know you got it working and glad to be of help.

I am facing similar problem where the headphone is not detected by system and not showing in sound settings.
After installing pavucontrol, I can set the output device as headphone (still showing unplugged) which give me sound to headphone.
I think pavucontrol force to send sound signal to headphone jack even it is not detected, which solves problem.
I think this is bug in fedora from long time.
This is bug URL:
Replying on this bug with any useful info would be great. Thanks.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.