*Some* Youtube videos won't play

YouTube videos will sometimes just give me this screen. Other videos will play just fine immediately after trying one that gives me this screen.

Not even sure this is a Fedora problem, but I’ve only come across this behavior since moving to Fedora. Happens in Chromium and Firefox.

If anyone can point me in the right direction I’d appreciate it.

It is gone allready.

This video isn’t available anymore

If you new to fedora you might install plugins and codecs:

1 Like

Thanks. I’ll come back and mark it as solution in a few days if I don’t see the issue happen again.

To summarize my fix for similar problems, I did the following: (after enabling both the rpmfusion-free and rpmfusion-nonfree repos as shown here.)
sudo dnf install gstreamer1-plugins-ugly vlc gstreamer1-plugins-good-extras ffmpeg livavcodec-freeworld gstreamer1-plugin-openh264 --best --allowerasing
That command installed all the needed codecs and removed the conflicting packages.

Seems to have fixed it. The issue stopped. Thanks

Nope. Never mind. Seems to have happened right after I thought it was good again lol.

Hey, have you solved your issue? I came accross the same problem, but I was able to fix it by following these two guides:

Have you tried the flatpak version of Firefox? It could be a problem with codecs and the flatpak version includes them by default without having to install other packages.

I switched to the flatpak version of Firefox because the videos kept clicking and now they always play smoothly.

P.S. if you need to install gnome extensions with the flatpak version of Firefox use ‘Extension Manager’ by Matthew Jakeman (available in the Software application)

I had the same problem, and installing this solved it. Thank you.