Some Youtube videos don't play

Hi :slight_smile:

Currently running

  • Fedora Rawhide KDE
  • X11 session
  • All packages up to date (as of 17/19/23)
  • Firefox 117.01

So far most things work, but I’ve noticed some YouTube videos fail to play, I just get the error:

An error occurred. Please try again later. (Playback ID: [##########])

I’ve read in various places this has to do with codecs and I should install ffmpeg from Fusion repos rather than the ffmpeg-free version that ships with Fedora.

If I run this

sudo dnf5 install ffmpeg

It returns

Failed to resolve the transaction:
Problem: package ffmpeg-6.0-16.fc39.x86_64 requires ffmpeg-libs(x86-64) = 6.0-16.fc39, but none of the providers can be installed
  - conflicting requests
  - nothing provides libopenh264.so.7()(64bit) needed by ffmpeg-libs-6.0-16.fc39.x86_64

Here are my enabled repos

Repo ID           : rawhide
Name              : Fedora - Rawhide - Developmental packages for the next Fedora release
Status            : enabled
PGP               : 
  Keys            : 
  Verify repodata : 
  Verify packages : 

Repo ID           : copr:copr.fedorainfracloud.org:zeno:scrcpy
Name              : Copr repo for scrcpy owned by zeno
Status            : enabled
PGP               : 
  Keys            : 
  Verify repodata : 
  Verify packages : 

Repo ID           : fedora-cisco-openh264
Name              : Fedora rawhide openh264 (From Cisco) - x86_64
Status            : enabled
PGP               : 
  Keys            : 
  Verify repodata : 
  Verify packages : 

Repo ID           : rpmfusion-nonfree-rawhide
Name              : RPM Fusion for Fedora Rawhide - Nonfree
Status            : enabled
PGP               : 
  Keys            : 
  Verify repodata : 
  Verify packages : 

Repo ID           : rpmfusion-free-rawhide
Name              : RPM Fusion for Fedora Rawhide - Free
Status            : enabled
PGP               : 
  Keys            : 
  Verify repodata : 
  Verify packages :

Is there something that I’m missing or haven’t done properly?

Thanks

The following Quick Docs may help resolve it.

Thanks for that, unfortunately I’ve already tried that with the following results (I didn’t uninstall lame):

sudo dnf install gstreamer1-plugins-{bad-\*,good-\*,base} gstreamer1-plugin-openh264 gstreamer1-libav --exclude=gstreamer1-plugins-bad-free-devel 
Last metadata expiration check: 0:22:17 ago on Sun 17 Sep 2023 21:02:25.
Package gstreamer1-plugins-bad-free-1.22.5-1.fc39.x86_64 is already installed.
Package gstreamer1-plugins-good-qt-1.22.5-1.fc39.x86_64 is already installed.
Package gstreamer1-plugins-good-qt6-1.22.5-1.fc39.x86_64 is already installed.
Package gstreamer1-plugins-base-1.22.5-1.fc39.x86_64 is already installed.
No match for argument: gstreamer1-plugin-openh264
Package gstreamer1-plugin-libav-1.22.5-1.fc39.x86_64 is already installed.
Error: Unable to find a match: gstreamer1-plugin-openh264

sudo dnf install lame\* --exclude=lame-devel
Last metadata expiration check: 0:22:31 ago on Sun 17 Sep 2023 21:02:25.
Package lame-libs-3.100-15.fc39.x86_64 is already installed.
Dependencies resolved.
======================================================================================================================================================================================
 Package                                 Architecture                              Version                                           Repository                                  Size
======================================================================================================================================================================================
Installing:
 lame                                    x86_64                                    3.100-15.fc39                                     rawhide                                    142 k

Transaction Summary
======================================================================================================================================================================================
Install  1 Package

Total download size: 142 k
Installed size: 464 k
Is this ok [y/N]: ^COperation aborted.

sudo dnf group upgrade --with-optional Multimedia
Last metadata expiration check: 0:22:40 ago on Sun 17 Sep 2023 21:02:25.
No match for group package "gimp-heif-plugin"
No match for group package "gstreamer1-plugin-openh264"
Error: 
 Problem 1: package ffmpeg-6.0-16.fc39.x86_64 from rpmfusion-free-rawhide requires ffmpeg-libs(x86-64) = 6.0-16.fc39, but none of the providers can be installed
  - conflicting requests
  - nothing provides libopenh264.so.7()(64bit) needed by ffmpeg-libs-6.0-16.fc39.x86_64 from rpmfusion-free-rawhide
 Problem 2: problem with installed package libavcodec-free-6.0-12.fc40.x86_64
  - conflicting requests
  - nothing provides libopenh264.so.7()(64bit) needed by libavcodec-freeworld-6.0-16.fc39.x86_64 from rpmfusion-free-rawhide
 Problem 3: problem with installed package firefox-117.0.1-2.fc40.x86_64
  - conflicting requests
  - ffmpeg-libs-6.0-16.fc39.i686 from rpmfusion-free-rawhide  does not belong to a distupgrade repository
  - nothing provides libopenh264.so.7()(64bit) needed by ffmpeg-libs-6.0-16.fc39.x86_64 from rpmfusion-free-rawhide
(try to add '--skip-broken' to skip uninstallable packages)

dnf5 was tested then removed from F39 because it was not ready.

Have you tried using dnf instead of dnf5.

Yes I’ve tried with dnf also, but get the same issues unfortunately

If I

sudo dnf install ffmpeg

I get

nothing provides libopenh264.so.7()(64bit) needed by ffmpeg-libs-6.0-16.fc39.x86_64 from rpmfusion-free-rawhide

What I don’t understand is I do have the fedora-cisco-openh264 repo enable, so why wouldn’t the package needed be pulled down from there?

Other people seem to have this issue but I can’t find a solution that doesn’t fall back on installing ffmpeg-free - which I don’t want.

Can you verify that by running dnf repolist and/or dnf5 repolist. You provided a list earlier, but I can’t see how you created that list. If the list was not created by the dnf command, it may not be a valid list.

Yes definitely using dnf now, the issues remains the same

Could you try Chromium browser?

In the end I installed Debian sid - everything is working as it should, and then some, was able to get waydroid working too.

Sorry Fedora, you’re not for me :slightly_frowning_face:

Root cause (at the time of this writing!) is that the relevant codecs repository is missing all the packages, see Rawhide (40) missing openh264 - Fedora Discussion (fedoraproject.org)

Since you are commenting on rawhide and codecs you really should be aware of what rawhide is.

Rawhide is the development environment which is where packages are being upgraded and tested. Users should only be running rawhide if they are participating in the testing process for the upgrades and new software since it frequently sees broken packages and is far from stable.

For this reason it seems rpmfusion does not do the multimedia stuff for rawhide, but only for the released and beta versions. Since 39 is released the packages are available there, but not for rawhide. When 40 becomes branched then beta those codecs will appear for 40, but probably not until then.

1 Like

yes, fedora repos for codes with some proprietary drivers done the trick for me for playing and recording videos, & Debian is too baremetal

rawhide is the most aggressive, most unstable, most bleeding edge, most alpha formally-unreleased-yet-packaged of the Fedora Linux distribution available.

Well, at least that’s my understanding of rawhide.

It also happens to package the KDE Plasma 6.0 desktop environment at their git master (which I would love to properly test-drive on Wayland, with all codecs and what not, and possibly hack on that a bit to look into regressions there).

That is a wonderful idea. How about you assist the developers & packagers at rpmfusion to provide those codecs for the bleeding edge stuff in rawhide. :innocent:

That would seem a possible solution since you could have a hand in testing things as well as providing the updates for others. :sunglasses:

More assistance would probably be very much appreciated in their already busy schedules.