Some Weird system halts

 /sbin/lspci| grep -e VGA
00:02.0 VGA compatible controller: Intel Corporation Iris Plus Graphics G7 (rev 07)

 /sbin/lspci| grep -e 3D 
01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX330] (rev a1)

Please help with 100% working solution
as its my main computer

You have 2 options:
1-If you don’t play games or do any graphics intensive workload you could just blacklist nouveau and use your intel iris graphics only.
simply do the following:
sudo nano /etc/modprobe.d/blacklist.conf
write in this file:
blacklist nouveau
Press Ctrl-X then Y then enter to save the file.
This is only if you don’t need the nvidia card (you need it I think)

2- You can install nvidia proprietary driver following this guide:

Personally I do not use the Nvidia GPU I have since it isn’t that much better than the iGPU and it overheats quickly (thanks HP for not enough cooling)

what to do according to you
I may have to use gpu in some point of time in future

Install proprietary nvidia drivers then. (option 2)

Done, :crossed_fingers:

So is your problem solved?, you should add [Solved] to the title and accept the solution that fixed your problem.

Have to wait for a day or two
to verify