Some video thumbnails on Nautilus are not generated on Silverblue 40

Hello, I am currently using Silverblue 40 and I am experiencing an issue where Nautilus is not generating thumbnails for certain videos. Do you have any suggestions on how to resolve this issue?

Hello, welcome to the Fedora community.

By default, Nautilus does not generate thumbnails for videos due to patent restrictions. To enable thumbnail generation for common video formats like MP4 and MKV, you first need to add the RPM Ffusion repository, and then install the necessary thumbnailer and software codec. You also need to delete existing thumbnails.

This command adds the RPM Fusion free and non-free repositories and will reboot once completed:

rpm-ostree install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm -r

After rebooting, this command transfers the rpm-fusion repositories from local packages to layered packages, reducing potential issues during major updates:

rpm-ostree update --uninstall rpmfusion-free-release --uninstall rpmfusion-nonfree-release --install rpmfusion-free-release --install rpmfusion-nonfree-release

This command installs the thumbnailer and codecs for thumbnail generation and will reboot once completed:

rpm-ostree install ffmpegthumbnailer libavcodec-freeworld -r

After rebooting, delete the existing thumbnails:

rm -rf ~/.cache/thumbnails

why do you uninstall and install the same packages?

See Simplifying updates for RPM Fusion packages (and other packages shipping their own RPM repos)


Thank you so much for the solution, It would be great if in the welcome screen there would be an option to install those codecs in the same way you can activate third party repositories nowadays.

This is not possible due to legal reasons.

Why Ubuntu can put it as an option on the installer and Fedora can’t?

I can not speak about Ubuntu as I don’t know. For Fedora, see: