Some funky findings using the MX Master 3 on Linux

Greetings fellow humans, human fellas.

I just wanted to take the time to share my experience with the new mouse. For office work, there is little on the market that competes with this mouse in terms of comfort, quality, features, etc. If you can shell out the rather expensive price, 120USD at the time I purchased, then this will be the best most you can buy. Don’t buy it for gaming though. The sensor is not fast enough to keep up.

Enough about the mouse itself. Here’s my experience with using it for a couple of weeks.

This mouse can connect up to 3 devices at the same time, and you can switch between them using the button on the bottom. 1 connects to the USB receiver, 2 and 3 connect via Bluetooth.

Using the receiver for my desktop(EndeavourOS) it connected immediately with no issues at all. However, some features were missing compares to Windows or Mac, specifically the copy flow feature. The receiver had no issues connecting and disconnecting between restarts or logins. Note that the mouse seems to not work when you are on the login screen(GDM). I am unsure if this is normal or if this is a bug with GDM.

Bluetooth options worked well as well. Though, on Arch, it took around 7 seconds for the machine to recognize the mouse. On Fedora, this issue does not seem to happen.

However, there is one issue I’ve noticed in the Bluetooth modes. Weirdly, when I restart the system or come back from suspension, the mouse often has connection issues. Sometimes it works well, sometimes it refuses to work entirely despite Gnome settings reporting that the mouse is connected. Removing the device from Gnome settings and re-pairing fixed the issue. This issue only seems to happen on my Lenovo laptop with EndeavourOS. My LG Gram with Fedora does not have this issue so this might be an issue with this specific laptop.

For configuring mouse settings(DPI, polling rate, etc), Solaar seems to work best. I’ve tried both Piper and solar. On EndeavourOS, Piper had this weird issue where the settings would reset themselves. Re-booting the system seems to rectify this issue. This again only happened on my Lenovo laptop, not on the desktop or Fedora LG gram so it might be an issue with the Laptop itself.

Solaar on the other hand worked with flying colors out of the box. While you aren’t able to create custom keybindings as piper does, Solaar provides other tweaks that make it more useful than piper. You can change the scroll wheel sensitivity, direction, rachet sensitivity, etc. These settings seem to stick with the mouse regardless of what machine I use so that’s a plus. Though, On Fedora, Solaar did not appear on Gnome-Software despite being included in the stock repos. Apps not showing in the app store GUI is a common issue I seem to be having.

Overall, despite some of the weird issues on EndeavourOS, I really like using this mouse and I recommend any office worker to use it as well. It will serve you well for the next 4 to 5 years to come before Logitech releases the next version of this mouse.

I hope you all have a pleasant day.

Waddle on!

Which version of Solaar were you using? The latest (1.0.5) does have the custom keybindings feature if I remember correctly.

As for your Bluetooth issues, they would need some diagnosis.

Yes. Solaar I used does have some rebinding capability,. thought they wer nt as robust as those found on Piper.

The bluetooth isues wre stricktly only seen on Arch so no issues there.

I had never heard of Solaar before, I have been able to configure the DPI to make the mouse faster, this is great, thanks.