[Solved]Need help with setting up grub-btrfsd and snapshot grub entry doesnt show

Hello, I followed this updated guide to this.
Btw, I did succesfully installed and configured grub-btrfsd and service is running well, I have Timeshift created snapshots, BUT… Snapshot entry is missing on my GRUB2.06… I am desperate on this now and frustrated, on my Rosa Fresh Linux 12.4 installation I had everithing worked perfectly well with Timeshift and Grub-Btrfsd snapshots. I followed exactly the same giude here. And now on my Nobara Linux v37 KDE i cannot get it fully working coz of its entry of Timeshift snapshots is missing from grub menu. I switched to Nobara Linux coz it is more up to date with gamming stuf then Rosa Linux and repos are more maintained coz it using Fedoras to. Please could someone help me, thx…

[CODE]┬─[stefanm@OptimusPrime-PC:~]─[15:37:47]
╰─>$ sudo systemctl status grub-btrfsd
[судо] лозинка за корисника stefanm:
● grub-btrfsd.service - Regenerate grub-btrfs.cfg
Loaded: loaded (/etc/systemd/system/grub-btrfsd.service; enabled; preset: disabled)
Active: active (running) since Fri 2023-06-16 15:19:19 CEST; 18min ago
Main PID: 1025 (bash)
Tasks: 3 (limit: 19041)
Memory: 16.8M
CPU: 2.351s
CGroup: /system.slice/grub-btrfsd.service
├─1025 bash /usr/bin/grub-btrfsd --syslog --timeshift-auto
├─1051 bash /usr/bin/grub-btrfsd --syslog --timeshift-auto
└─4956 inotifywait -q -q -e create -e delete /run/timeshift

lip 16 15:29:35 OptimusPrime-PC root[4317]: 20microsoft: debug: Skipping legacy bootloaders on UEFI system
lip 16 15:29:35 OptimusPrime-PC root[4317]: os-prober: debug: running /usr/libexec/os-probes/mounted/30utility on mounted /dev/sd>
lip 16 15:29:35 OptimusPrime-PC root[4317]: 30utility: debug: /dev/sdc2 is not a FAT partition: exiting
lip 16 15:29:35 OptimusPrime-PC root[4317]: os-prober: debug: running /usr/libexec/os-probes/mounted/40lsb on mounted /dev/sdc2
lip 16 15:29:35 OptimusPrime-PC root[4317]: os-prober: debug: running /usr/libexec/os-probes/mounted/70hurd on mounted /dev/sdc2
lip 16 15:29:35 OptimusPrime-PC root[4317]: os-prober: debug: running /usr/libexec/os-probes/mounted/80minix on mounted /dev/sdc2
lip 16 15:29:35 OptimusPrime-PC root[4317]: os-prober: debug: running /usr/libexec/os-probes/mounted/83haiku on mounted /dev/sdc2
lip 16 15:29:35 OptimusPrime-PC root[4317]: 83haiku: debug: /dev/sdc2 is not a BeFS partition: exiting
lip 16 15:29:35 OptimusPrime-PC root[4317]: os-prober: debug: running /usr/libexec/os-probes/mounted/90linux-distro on mounted [/CODE]

[CODE]cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=345E-3F32 /boot/efi vfat defaults,noatime 0 2
UUID=b11d0dfa-2e2c-4bc1-9d7f-d9d5f9cb57c7 /boot ext4 defaults,noatime 0 2
UUID=d58f438e-313d-452b-a4ef-94bde9a48f8a / btrfs subvol=/@,compress=zstd:1,x-systemd.device-timeout=0,defaults,noatime,discard=async 0 0
UUID=d58f438e-313d-452b-a4ef-94bde9a48f8a /home btrfs subvol=/@home,compress=zstd:1,x-systemd.device-timeout=0,defaults,noatime,discard=async 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
/dev/sdc1 /mnt/sdc1 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/sdc2 /mnt/sdc2 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/sdb1 /mnt/sdb1 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/sdb2 /mnt/sdb2 auto nosuid,nodev,nofail,x-gvfs-show 0 0[/CODE]

mount | grep home /dev/sda3 on /home type btrfs (rw,noatime,compress=zstd:1,ssd,discard=async,space_cache=v2,subvolid=257,subvol=/@home)

EDIT: Got it working, I explained it there.

Nobara is not fedora, and it is known they use different boot methods. This seems like something that should be addressed specifically to the nobara team at https://nobaraproject.org/

1 Like

Well this was worked last time, around 5 months ago, I tried and used Nobara. And now it is working like I explained on this link. For my Rosa Fresh Linux 12.4 worked to, even Rosa isnt Fedora at all.

I am trying to follow that sysguides tutorial, but it did not actually get the snapshots submenu to appear in the Grub menu.

Timeshift was not my first option. I can handle snapper for the time being, as all the snashop activities are there. Plus I added btrfs-assistant and its a GUI for browsing/creating and restoring the snaphots.

You are doing something wrong, look on github page for grub-btrfsd for updated instructions, and for installing Fedora, Nobara or some of Mandriva forks. I can asure you that it is working.Recently I installed Rosa Fresh Desktop 13 Alpha and I seted up Timeshift with no problem with grub-btrfsd.