(Solved) Heads up - black screen on Windows Remote Desktop connection to Silverblue NVIDIA laptop after rpm-ostree upgrade

I have a Windows 11 system with an NVIDIA RTX 3090 and an Acer Nitro 5 with an NVIDIA GTX 1650 running Silverblue 39. I’ve been running the Silverblue system with GNOME on Xorg and connecting to it with Windows Remote Desktop.

Today the rpm-ostree upgrade upgraded some NVIDIA packages to

xorg-x11-drv-nvidia-kmodsrc-550.54.14-1.fc39.x86_64
xorg-x11-drv-nvidia-cuda-libs-550.54.14-1.fc39.x86_64
nvidia-modprobe-550.54.14-1.fc39.x86_64
xorg-x11-drv-nvidia-libs-550.54.14-1.fc39.x86_64
nvidia-settings-550.54.14-1.fc39.x86_64
xorg-x11-drv-nvidia-power-550.54.14-1.fc39.x86_64
xorg-x11-drv-nvidia-550.54.14-1.fc39.x86_64
akmod-nvidia-550.54.14-1.fc39.x86_64
kmod-nvidia-550.54.14-1.fc39.x86_64

After the upgrade, the Windows remote desktop connection returned only a black screen. Changing the login on the laptop from GNOME on Xorg to regular GNOME (on Wayland) fixed this.