Software Center disappeared, error message when trying to install


I suspect someone messed my machine by removing the software center which I liked to use to see the changelog of the updates.

I found the name of the package is gnome-software, however, when I try to dnf install this package I get the following message:

[guilherme@pc ~]$ gnome-software
bash: gnome-software: comando não encontrado...
Instalar pacote "gnome-software" para fornecer o comando "gnome-software"? [N/y] y

 * Esperando na fila... 
 * Baixando lista de pacotes.... 
 * Baixando detalhes sobre os repositórios de software.... 
 * Baixando lista de pacotes.... 
Os seguintes pacotes têm que ser instalados:
 flatpak-1.4.2-4.fc30.x86_64	Application deployment framework for desktop apps
 gnome-software-3.32.4-2.fc30.x86_64	A software center for GNOME
Os seguintes pacotes têm que ser desatualizados:
 flatpak-selinux-1.4.2-4.fc30.x86_64	SELinux policy module for flatpak
 flatpak-session-helper-1.4.2-4.fc30.x86_64	User D-Bus service used by flatpak and others
Continuar com as alterações? [N/y] y

 * Esperando na fila... 
 * Esperando pela autenticação... 
 * Esperando na fila... 
 * Baixando pacotes... Falha ao instalar pacotes: Cannot download Packages/f/flatpak-session-helper-1.4.2-4.fc30.x86_64.rpm: All mirrors were tried; Last error: Status code: 404 for

[guilherme@pc ~]$ 

I’m using Fedora 30, any help or guidance is welcome.

Thank you

It is trying install a package from this repo:

In this repo don’ t exit this package becouse it is a old version, if you look into the repo you can see than it package is 1.4.3-1 in place of 1-4-2-4.

So lets try first with a global update of the system and see if this resolve the issue.

  1. sudo dnf clean all

  2. sudo dnf --refresh upgrade

  3. sudo dnf install gnome-software

If the first option did not the work try remove this package and install it again

sudo dnf remove flatpak-selinux

sudo dnf --refresh upgrade

sudo dnf install gnome-software

sudo dnf install flatpak-selinux



Thank you for your help, the computer is at work, I will follow your instructions once I get there.

Do you believe someone could intentionally cause this issue?

I installed and updated Fedora on a VM to check if it could be a bug in some update and the Software Center, after all updates, was still there and working on the VM.

I ask this because I found out a coworker was constantly accessing my computer to wget stuff he wasn’t supposed to download, he also has something personal against me and since hes skilled enough he could just mess my computer to enjoy watching me “suffer” trying to fix.

If you are suspicius you can type in console the command history that will show you a list complete of all the orders executed in the terminal by the user. So you can see all changes done via console and reverse them if necesary.


Good idea however he can edit the bash history no?

This worked, thank you very much!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.