So what changed in grub2 when updating Fedora 35 to 36?

Hi all,

I have upgraded my Fedora 35 to 36. Did not change anything to my /etc/default/grub, as always never needed after upgrade. Suddenly my grub2 background -although found when generating grub.conf- doesn’t show up anymore and my grub menu borders are all the wrong characters.
Using GRUB_ENABLE_BLSCFG=“false”, as always.

Anyone knows what is going on here?

Fedora uses an alternative path than grub. If you use a grub theme you have to manually change the path alias using the correct sub directories.

Did you manually recreate grub.cfg using grub2-mkconfig or not?
If you did please provide the entire command line you used to do that.

Thanks for your answeres, but the thing is, i didn’t change anything for F36 and in F35 everything was all right (as in F34, 33, 32 etc).
So it is not at my side, it is grub2 in F36. All paths are fine, typeface DejaVuSansMono.pf2 is also found; worked flawlessly in F35 and before, but not in F36.
Other character set of grub2 maybe? Better facetype for grub2 in F36?

Had some grub* updates today, seems fixed, everything same as in F35 now, will tag this as “solved”

1 Like