Snaps on F38 have two mountpoints / mounted twice

Hello all,

There’s a small issue that I’ve noted on F38. I first saw it on my main laptop (F38 with Gnome, with as few changes as possible) and confirmed it’s the same on all my virtual installs (including F38 i3 spin) while it’s not present on another laptop with F37. It’s also not present on an Ubuntu VM.

So using lsblk -pf or mount or findmnt or whatever shows each snap mounted twice. For instance with lsblk:

/dev/loop1    squashfs    4.0    0    100%    /var/lib/snapd/snap/bare/5

And with mount:

/var/lib/snapd/snaps/bare_5.snap on /var/lib/snapd/snap/bare/5 type squashfs (ro,nodev,relatime,context=system_u:object_r:snappy_snap_t:s0,errors=continue)
/var/lib/snapd/snaps/bare_5.snap on /var/lib/snapd/snap/bare/5 type squashfs (ro,nodev,relatime,context=system_u:object_r:snappy_snap_t:s0,errors=continue,x-gdu.hide,x-gvfs-hide)

This was only mounted once on F37 (the second line on the mount output, with mount options:


And this is the same on the Ubuntu VM.

I have tried to dig a bit but I’m not familiar with how snaps work and I did not see anything different in cat’ing the snapd.mounts* or looking in the files in /var/lib/snapd/mount.

I suppose that there are more important things and I’m not even sure it’s a bug worth opening, but that’s itching my OCD (having one filesystem per snap was annoying enough, now it’s two…). I suppose I’m more interested to understand why.

(and before any suggestion to use flatpak, I use it and prioritise flatpak overall, but I prefer snaps when the vendor publishes directly on the snapstore and not on flathub, to me it’s more secure)

I have never use snap so am not familiar with it.

Fedora seems to prefer the use of flatpak over snap.